disable the night texture?

Report bugs, bug fixes and workarounds here.
Topic author
alexdudek
Posts: 1
Joined: 05.09.2018
With us: 4 months 16 days

disable the night texture?

Post #1by alexdudek » 05.09.2018, 08:54

Not really a bug...more a request on looks...Is there a way to disable the night texture on the dayside for the next version of Celestia?

Avatar
Croc M
Forum Admin
Posts: 412
Joined: 10.08.2016
Age: 71
With us: 2 years 5 months
Location: Udomlya, Tver region, Russia

Post #2by Croc » 05.09.2018, 13:06

The night texture is turned off in Celestia 1.6.1.
This option will be preserved in Celestia 1.7.0.

ViewOptions.jpg

Avatar
gironde M
Posts: 330
Joined: 16.12.2016
Age: 66
With us: 2 years 1 month
Location: Montigny-Les-Metz, Grand Est, Lorraine, Moselle, France

Post #3by gironde » 06.09.2018, 15:15

Croc,

I think the setting you are showing is for night light only.
alexdudek talks about nighttime textures.
The textures of nights for a planet, for example, are located in the .ssc.

Look in solarsys.ssc, for Earth, there is the instruction NightTexture "earthnight. *"

To no longer see them on the screen, just write #NightTexture "earthnight. *" for put the line to comment. If you want to have them on demand, you may have to try AltSurface.


:hi:

Avatar
Croc M
Forum Admin
Posts: 412
Joined: 10.08.2016
Age: 71
With us: 2 years 5 months
Location: Udomlya, Tver region, Russia

Post #4by Croc » 06.09.2018, 19:46

#3by gironde » Today, 18:15
Croc,
gironde,
1. I do not know English, so I can not understand the question.
2. Based on your answer, you do not quite understand the question correctly.

The question reads:
Not really a bug...more a request on looks...Is there a way to disable the night texture on the dayside for the next version of Celestia?
Translating to Russian language:
На самом деле это не ошибка...больше запрос на внешний вид...есть ли способ отключить ночную текстуру на дневной стороне для следующей версии Celestia?

In the solarsys.ssc (22.01.2011) file there is a link to the night texture:

Code: Select all

"Earth" "Sol"
{
   Texture "earth.*"
   NightTexture "earthnight.*"
.....................................


Night texture earthnight.jpg (22.01.2011) is in the folder ..\textures\medres. Here is the texture:

earthnight.jpg


I agree with you to disable the night texture, you can edit the solarsys.ssc file as follows:

Code: Select all

"Earth" "Sol"
{
   Texture "earth.*"
   # NightTexture "earthnight.*"
.....................................


I suggested an easier way - to disable the night texture in the "View Options" panel.
===================
Carefully read the question: "...disable the night texture on the dayside..."

I do not understand what caused this question?
The night texture does not distort the view of the Earth during the day.

earthnight-2.jpg


earthnight-3.jpg

Avatar
gironde M
Posts: 330
Joined: 16.12.2016
Age: 66
With us: 2 years 1 month
Location: Montigny-Les-Metz, Grand Est, Lorraine, Moselle, France

Post #5by gironde » 07.09.2018, 08:38

in my ssc for Earth, the normal texture is Earth.ctx (VT textures) and NightTexture is earthnight.ctx (VT textures). The difference is very subtle almost invisible.


:hi:

Avatar
jujuapapa
Posts: 49
Joined: 24.06.2018
With us: 6 months 27 days

Post #6by jujuapapa » 22.12.2018, 13:13

Hi,

On celestia 1.6.1 or 1.7, night textures are turn OFF ? :insane:

CTRL L doesn't work ! :fie:

Why ?
PC : Intel Core i9-7920X (2.9 GHz) , Chipset X299 Exp, RAM 32 Go DDR4 3000 Mhz, SSD M.2 512 Go + HDD 2 To, NVIDIA GeForce GTX 1080 Ti 11Go

=> It is by doubting everything that one approaches the truth !

Avatar
selden
Posts: 10022
Joined: 04.09.2002
With us: 16 years 4 months
Location: NY, USA

Post #7by selden » 22.12.2018, 21:53

Night Textures are not visible if Celestia is in "Render path: Basic".

Type a Ctrl-V several times to step through the rendering modes which are available on your computer. "Render path: OpenGL 2.0" provides the most eye candy.
Selden

Avatar
jujuapapa
Posts: 49
Joined: 24.06.2018
With us: 6 months 27 days

Post #8by jujuapapa » 24.12.2018, 06:22

Yes, it works fine !

Thank you very much Selden, you're the best ! :clap:

Merry Christmas...
PC : Intel Core i9-7920X (2.9 GHz) , Chipset X299 Exp, RAM 32 Go DDR4 3000 Mhz, SSD M.2 512 Go + HDD 2 To, NVIDIA GeForce GTX 1080 Ti 11Go

=> It is by doubting everything that one approaches the truth !

Avatar
selden
Posts: 10022
Joined: 04.09.2002
With us: 16 years 4 months
Location: NY, USA

Post #9by selden » 24.12.2018, 12:37

You're very welcome.

Happy holidays!
Selden


Return to “Bugs”

Who is online

Users browsing this forum: 2 guests
Bots: Google [Bot]