Compiling CVS Issues

The place to discuss creating, porting and modifying Celestia's source code.
Topic author
toadatrix
Posts: 7
Joined: 28.10.2004
With us: 14 years 11 months

Compiling CVS Issues

Post #1by toadatrix » 28.10.2004, 14:10

I have successfully compiled the CVS version of Celestia on my SuSE 9.1 Pro linux system. I have a couple of questions, however.

1) Is the proper way to include lua to use --with-lua-inc=DIR OR --with-lua-includes=DIR (or is it --with-lua-include=DIR, without the "s" on include)? I know that the configure help file says use --with-lua-includes, but when I was compiling Celestia 1.3.2 the only way I could get lua support to work was by using --with-lua-inc. Is the configure help correct and which should I be using in the latest CVS of celestia?

2) After I compile the CVS is there any way I can get it to run from its build directory rather than having to install it with "make install"? I would like to be able to test the CVS version without screwing up my install of the stable 1.3.2 version. In other words, I would like to be able to get both 1.3.2 and CVS working on my system at the same time. Can this be done and how?

I am running from KDE 3.2. My standard configure script for compiling the CVS is as follows (subject to the lua-includes question above):

./configure --with-kde --with-lua-inc=/usr/include/lua --with-lua-libs=/usr/lib --prefix=/opt/kde3

Thanks so much for any help in clearing this up for me.

Return to “Development”

Who is online

Users browsing this forum: 42 guests