Page 49 of 51

Posted: 24.02.2021, 07:08
by onetwothree
John Van Vliet wrote:this is the error
Sounds like an error recently fixed by Markerz. Could you update the master branch and recheck?

Posted: 24.02.2021, 09:24
by Markerz
John Van Vliet wrote:this is the error
can you type `bt` here and enter, it should print a backtrace of the thread.

Posted: 05.05.2021, 23:31
by cartrite
When eigen3 and fmt was removed it broke the build process.

Posted: 06.05.2021, 07:24
by onetwothree
cartrite wrote:When eigen3 and fmt was removed it broke the build process.

What system do you use?

Posted: 07.05.2021, 00:09
by cartrite
right now I running an "All in One" HP with windows 10 on the hard drive. Its's basically a monitor with a motherboard. A cheap one at that. But I'm running suse 15.2 on 2 external drives. A 4 Tib and an older 2 Tib. My original 1 Tib drive which runs suse 42.3 is where it fails. eigen 3.2 is installed but i did manage to also install eigen 3.3. It doesnt find it. I built celestia on the other 2 drive but this was prior to May 2 when eigen and fmt where removed. I haven't tried yet because of major issues getting linux to run on this new computer, My old Toshiba Satellite finnaly bit the dust. I haven't tried to build celestia on windows yet but I did install visual studio express 19.

Added after 5 minutes 24 seconds:
Markerz wrote:
John Van Vliet wrote:this is the error
can you type `bt` here and enter, it should print a backtrace of the thread.

John, your in China now?? :wink: I just noticed the info on your avatar box.

Added after 4 minutes 14 seconds:
oh sorry forget that john. I now realize that I was looking at Markerz info.

Should have known You got the penguin avatar

Posted: 08.05.2021, 10:47
by onetwothree
cartrite wrote:My original 1 Tib drive which runs suse 42.3 is where it fails. eigen 3.2 is installed but i did manage to also install eigen 3.3.

How did install Eigen3? I suppose you don't have FindEigen3.cmake installed (i've checked https://build.opensuse.org/package/view_file/open ... tall_FindEigen3.patch?expand=1). As Eigen is a header only library you can try to install it from 15.x (see https://build.opensuse.org/package/show/openSUSE:Backports:SLE-15/eigen3) or take file FindEigen3.cmake from eigen3 source package and put it into Celestia/cmake.

Posted: 09.05.2021, 00:53
by cartrite
I gave up for now installing celestia on 42.3 but I'm having another issue trying to build on windows 10 using vs 2019,

Code: Select all

winmain.obj : error LNK2001: unresolved external symbol "int debugVerbosity" (?debugVerbosity@@3HA) [C:\Celestia\Celest
ia\build\src\celestia\win32\celestia-win.vcxproj]
C:\Celestia\Celestia\build\src\celestia\win32\Debug\celestia-win.exe : fatal error LNK1120: 1 unresolved externals [C:\
Celestia\Celestia\build\src\celestia\win32\celestia-win.vcxproj]

Everything builds then that. :rambo: Anyhow 42.3 has long ago reached eol. I don't need to build celestia on that system. I only tried to restore it because that's the only linux system that was able to play tv I like shows on the internet. leap 15x cant. I'm gonna look into this link error and let you guys know if I get it working.

Posted: 09.05.2021, 05:49
by chandra

Posted: 09.05.2021, 08:26
by cartrite
I have Celestia built and running on my opensuse leap 15.2 systems. Thank you chandra but I'm not looking for a binary. Anyhow, I think I found the reason for the link error with windows. For some reason the file wglext.cpp fails to build. I get over a hundred errors from wglext.h. Undefined errors, syntax errors. For some reason the compiler quits trying to build that file after 100 errors and continues to build the rest of the files, then tries to link. First time that ever happened to me. Usually, the compiler quits after the first error. Don't know whats wrong with wglext.h yet tho. Must be missing something in MSVC. A portion of the terminal output.

Code: Select all

  wglext.cpp
C:\projects\Celestia\src\celestia\win32\wglext.h(311,16): error C2065: 'HPBUFFERARB': undeclared identifier [C:\project
s\Celestia\build\src\celestia\win32\celestia-win.vcxproj]
C:\projects\Celestia\src\celestia\win32\wglext.h(311,27): error C4430: missing type specifier - int assumed. Note: C++
does not support default-int [C:\projects\Celestia\build\src\celestia\win32\celestia-win.vcxproj]
C:\projects\Celestia\src\celestia\win32\wglext.h(314,16): error C2065: 'HPBUFFEREXT': undeclared identifier [C:\project
s\Celestia\build\src\celestia\win32\celestia-win.vcxproj]
C:\projects\Celestia\src\celestia\win32\wglext.h(314,27): error C4430: missing type specifier - int assumed. Note: C++
does not support default-int [C:\projects\Celestia\build\src\celestia\win32\celestia-win.vcxproj]
C:\projects\Celestia\src\celestia\win32\wglext.h(314,1): error C2374: 'DECLARE_HANDLE': redefinition; multiple initiali
zation [C:\projects\Celestia\build\src\celestia\win32\celestia-win.vcxproj]


Added after 3 hours 27 minutes:
Celestia 1.7.0 Development Thread
The main reason I still wanted to use suse 42.3 was that it was what I used with the Toshiba and it was able to play any video on the net. TV shows movies etc. But 42.3 running on this computer can't play them anyhow. Maybe some day I'll figure out the build issue but it's not a priority. Anyhow I did get Celestia to build on Windows. I had gles set to on. :silenced: I wasn't aware that windows 10 was supporting a decent Opengl. While running Celestia reports

Code: Select all

OpenGL Version: 4.6.148201 Compatibility Profile Context 20.50.02.04 27.20.15002.4001
Vendor: ATI Technologies Inc.
Renderer: AMD Radeon(TM) R3 Graphics
GLSL Version: 4.60
Max simultaneous textures: 8
Max texture size: 16384
Point size range: 1 - 63
Line width range: 1.000000 - 63.000000
Point size granularity: 0.12
Number of interpolators: 128
Max anisotropy filtering: 16.00
So I'm happy with that.

Added after 50 seconds:
I didn't build the QT version. I only built win32.

Posted: 21.05.2021, 11:04
by john71
Art Blos wrote:Important information: This is the latest release based on the 1.6.x versions.
We are starting migration to 1.7.0.

Would you be so kind to share us some information about the release of v1.7?

Posted: 21.05.2021, 11:18
by Art Blos
john71 wrote:Would you be so kind to share us some information about the release of v1.7?
If we are talking about Origin, then we will start doing something at the end of May.

Posted: 21.05.2021, 11:26
by john71
Art Blos wrote:If we are talking about Origin, then we will start doing something at the end of May.

Thanks for the quick reply. I mean you HAVE TO have a working copy of 1.7 to start the migration, right?

Posted: 21.05.2021, 11:28
by Art Blos
john71 wrote:Thanks for the quick reply. I mean you HAVE TO have a working copy of 1.7 to start the migration, right?
Right. I myself will try to build the installer for Windows from the repository.

Posted: 21.05.2021, 11:30
by john71
Nice. OK.

Posted: 31.05.2021, 15:16
by CM1215
Art Blos wrote:I myself will try to build the installer for Windows from the repository.
If you get the installer built, could you share it? I, too, would like to experiment with 1.7.0.

Posted: 31.05.2021, 15:29
by Art Blos
CM1215 wrote:If you get the installer built, could you share it? I, too, would like to experiment with 1.7.0.
The first working prototype has been created, but I still want to improve it before publishing. How long it will take, I don't know exactly.
At the moment I found that the CO is about 70% compatible with 1.7.0. In fact, I expected a worse situation.:biggrin:

Posted: 31.05.2021, 16:00
by john71
It would be very nice to have a pre-release version of 1.7 (Win10 64bit). Some of us have hundreds of add-ons and problems can arise. It would be useful to test the program with these add-ons before it gets released.

Posted: 01.06.2021, 19:52
by cartrite
When was the last time the celestia.iss script was updated? If this was done, creating an executable would be simple for all. I tried today, but there are so many files that get left out of the installation that are in the script which apparently are unnecessary. i made an attempt today with little success. But I'm looking into it. Keep in mind this is not an executable that runs with the QT screen. That script would create the win 32 executable, to run on Windows 10.

Posted: 02.06.2021, 05:30
by onetwothree
it was updated for 1.6.2, not for 1.7.0

Posted: 02.06.2021, 23:07
by cartrite
This is a guess. I'm thinking I could use the CMakeList file in the top dir as a guide to edit the iss file? I'm thinking that should inculde all the dll's and files.