Celestia 1.7.0 Development Thread

The place to discuss creating, porting and modifying Celestia's source code.
Avatar
LukeCEL
Posts: 317
Joined: 26.09.2017
With us: 2 years 8 months

Post #781by LukeCEL » 07.04.2020, 04:18

This fixes the crash, but now something strange has happened to all of the text and the galaxies.
font.png

Avatar
jujuapapa
Posts: 197
Joined: 24.06.2018
With us: 1 year 11 months
Location: Western E.U.

Post #782by jujuapapa » 07.04.2020, 05:17

Same thing at home ! :eek: :cry:
PC : Intel Core i9-9900K (4 GHz) , Chipset Z390 Exp, RAM 32 Go DDR4 3000 Mhz, SSD M.2 512 Go + HDD 3 To, MSI GeForce RTX 2080 8Go - W10 64b

=> It is by doubting everything that one approaches the truth !

Topic author
onetwothree
Developer
Posts: 460
Joined: 22.09.2018
With us: 1 year 8 months

Post #783by onetwothree » 07.04.2020, 05:22

missing shaders text_*.glsl and galaxy_*.glsl

Markerz
Developer
Posts: 139
Joined: 29.01.2009
Age: 24
With us: 11 years 4 months
Location: Hangzhou, China

Post #784by Markerz » 07.04.2020, 05:59

LukeCEL wrote:This fixes the crash, but now something strange has happened to all of the text and the galaxies.
font.png

Like onetwothree said, shaders are missing, copy those from the .zip/Celestia.app/Contents/Resources/CelestiaResources/shaders to the shaders folder where it read data from (in your case your 1.6.1 installation).

Avatar
jujuapapa
Posts: 197
Joined: 24.06.2018
With us: 1 year 11 months
Location: Western E.U.

Post #785by jujuapapa » 07.04.2020, 09:20

Markerz wrote:Like onetwothree said, shaders are missing, copy those from the .zip/Celestia.app/Contents/Resources/CelestiaResources/shaders to the shaders folder where it read data from (in your case your 1.6.1 installation).
None change ! :eek: :fie:
PC : Intel Core i9-9900K (4 GHz) , Chipset Z390 Exp, RAM 32 Go DDR4 3000 Mhz, SSD M.2 512 Go + HDD 3 To, MSI GeForce RTX 2080 8Go - W10 64b

=> It is by doubting everything that one approaches the truth !

Markerz
Developer
Posts: 139
Joined: 29.01.2009
Age: 24
With us: 11 years 4 months
Location: Hangzhou, China

Post #786by Markerz » 07.04.2020, 11:58

jujuapapa wrote:None change ! :eek: :fie:
hmmm, can you provide console output (press ~) and maybe launch from Terminal (or show package contents - Contents - macOS - Double click on Celestia) and see if there is any log output?

Avatar
jujuapapa
Posts: 197
Joined: 24.06.2018
With us: 1 year 11 months
Location: Western E.U.

Post #787by jujuapapa » 07.04.2020, 17:23

Markerz wrote:
jujuapapa wrote:None change ! :eek: :fie:
hmmm, can you provide console output (press ~) and maybe launch from Terminal (or show package contents - Contents - macOS - Double click on Celestia) and see if there is any log output?
ok, good luck to read this ?

20200407 pb 1.7.jpg


Perhaps with the file 'shaders.log'
shaders.log
(19.71 KiB) Downloaded 7 times
PC : Intel Core i9-9900K (4 GHz) , Chipset Z390 Exp, RAM 32 Go DDR4 3000 Mhz, SSD M.2 512 Go + HDD 3 To, MSI GeForce RTX 2080 8Go - W10 64b

=> It is by doubting everything that one approaches the truth !

Topic author
onetwothree
Developer
Posts: 460
Joined: 22.09.2018
With us: 1 year 8 months

Post #788by onetwothree » 07.04.2020, 17:26

show what do you have in shaders subfolder

Avatar
jujuapapa
Posts: 197
Joined: 24.06.2018
With us: 1 year 11 months
Location: Western E.U.

Post #789by jujuapapa » 07.04.2020, 17:30

onetwothree wrote:show what do you have in shaders subfolder
Subdirectory shaders contains 1.7 files + 1.6.2 files...
20200407 pb shaders.jpg

used with celestia-5772-txf-x64-RaDecDist.exe but ok with celestia-txf-x64.exe (from 12/15/2019) :wink:
PC : Intel Core i9-9900K (4 GHz) , Chipset Z390 Exp, RAM 32 Go DDR4 3000 Mhz, SSD M.2 512 Go + HDD 3 To, MSI GeForce RTX 2080 8Go - W10 64b

=> It is by doubting everything that one approaches the truth !

Avatar
LukeCEL
Posts: 317
Joined: 26.09.2017
With us: 2 years 8 months

Post #790by LukeCEL » 07.04.2020, 18:36

Thanks Markerz and onetwothree,

I added galaxy_frag.glsl, galaxy_vert.glsl, text_frag.glsl, and text_vert.glsl to my 1.6.1 installation. I also added star_frag.glsl and star_vert.glsl since the stars weren't showing. That seems to have fixed most of the red rectangles.

When start.cel runs, there's this giant red triangle that opens up when it selects the Sun or the Earth. So I'm probably missing some other shaders.

redarrow.png

Topic author
onetwothree
Developer
Posts: 460
Joined: 22.09.2018
With us: 1 year 8 months

Post #791by onetwothree » 07.04.2020, 20:28

jujuapapa wrote:show what do you have in shaders subfolder

Subdirectory shaders contains 1.7 files + 1.6.2 files...
And where are text_*.glsl?

LukeCEL wrote:So I'm probably missing some other shaders.
selpointer_*.glsl

just copy all shaders from github

Avatar
LukeCEL
Posts: 317
Joined: 26.09.2017
With us: 2 years 8 months

Post #792by LukeCEL » 07.04.2020, 20:35

onetwothree wrote:just copy all shaders from github

Good idea, now I think I don't have any more shader issues.

Added after 2 minutes 3 seconds:
Also, zooming in and out using Markerz's build is much faster, just like 1.6.1 :smile:

Markerz
Developer
Posts: 139
Joined: 29.01.2009
Age: 24
With us: 11 years 4 months
Location: Hangzhou, China

Post #793by Markerz » 08.04.2020, 01:55

it actually makes me feel that the shaders should be read from a specific place (not to be influenced by environment variables), or just hardcoded in a way in CPP code, since we don't actually read shaders other than the ones we have

Added after 2 minutes 40 seconds:
LukeCEL wrote:Also, zooming in and out using Markerz's build is much faster, just like 1.6.1 :smile:

Good to hear that, this is a total rewrite of UI on macOS. and hopefully would also be the foundation for future releases for macOS :wink:

Avatar
jujuapapa
Posts: 197
Joined: 24.06.2018
With us: 1 year 11 months
Location: Western E.U.

Post #794by jujuapapa » 08.04.2020, 05:29

@123: Great, it's OK, TY. :clap:
PC : Intel Core i9-9900K (4 GHz) , Chipset Z390 Exp, RAM 32 Go DDR4 3000 Mhz, SSD M.2 512 Go + HDD 3 To, MSI GeForce RTX 2080 8Go - W10 64b

=> It is by doubting everything that one approaches the truth !

Avatar
LukeCEL
Posts: 317
Joined: 26.09.2017
With us: 2 years 8 months

Post #795by LukeCEL » 08.04.2020, 14:57

Markerz wrote:Good to hear that, this is a total rewrite of UI on macOS. and hopefully would also be the foundation for future releases for macOS

That's great to hear! How was it compiled? I thought you could only compile the QT version on macOS.

Added after 1 hour 22 minutes:
onetwothree, is the CelestiaContent repo finalized? I just tried compiling 1.7.0 and I noticed that it did not install data, extras, models, etc.

Avatar
SevenSpheres
Forum Admin
Posts: 360
Joined: 08.10.2019
With us: 7 months 27 days

Post #796by SevenSpheres » 08.04.2020, 17:28

LukeCEL wrote:I just tried compiling 1.7.0 and I noticed that it did not install data, extras, models, etc.

That would not be good... (but not really surprising either...)
My Addons: viewtopic.php?f=23&t=19978 • Contributing to development as much as I can • The Other Discord is still there...
PC specs: HP desktop, Windows 10 Home 64-bit, Intel Core i7-7700 (3.60 GHz), 16 GB RAM, 1 TB HDD + 128 GB SSD, Intel HD Graphics 630
Celestia versions: 1.5.1, 1.6.1, 1.6.2 (primary), and multiple 1.7.0 builds

Topic author
onetwothree
Developer
Posts: 460
Joined: 22.09.2018
With us: 1 year 8 months

Post #797by onetwothree » 08.04.2020, 19:04

Update your git submodules:

Code: Select all

git submodule update --init


and when you run cmake to configure a build, pass an additional option to it:

Code: Select all

cmake ... -DENABLE_DATA=ON ...

Avatar
LukeCEL
Posts: 317
Joined: 26.09.2017
With us: 2 years 8 months

Post #798by LukeCEL » 08.04.2020, 19:10

onetwothree wrote:and when you run cmake to configure a build, pass an additional option to it:

Okay. I'm sure you're aware of this, but INSTALL.md does not yet include ENABLE_DATA as a parameter.

Markerz
Developer
Posts: 139
Joined: 29.01.2009
Age: 24
With us: 11 years 4 months
Location: Hangzhou, China

Post #799by Markerz » 09.04.2020, 02:12

LukeCEL wrote:How was it compiled? I thought you could only compile the QT version on macOS.

the part of UI code is not yet in Celestia repo. once I made it public, I would make documentation about making it work

Avatar
SevenSpheres
Forum Admin
Posts: 360
Joined: 08.10.2019
With us: 7 months 27 days

Post #800by SevenSpheres » 12.04.2020, 21:44

Some time ago support for Y-class brown dwarfs was added to Celestia. I've now made a pull request that adds the remaining missing spectral class: WO. As a bonus, here is an stc file with all 9 known WO stars. (Not a typo, they're very rare!) I've also added that link to the first post of my addon thread. The addon will still work in versions of Celestia without support for WO stars, but the stars will be displayed as spectral type WC.
My Addons: viewtopic.php?f=23&t=19978 • Contributing to development as much as I can • The Other Discord is still there...
PC specs: HP desktop, Windows 10 Home 64-bit, Intel Core i7-7700 (3.60 GHz), 16 GB RAM, 1 TB HDD + 128 GB SSD, Intel HD Graphics 630
Celestia versions: 1.5.1, 1.6.1, 1.6.2 (primary), and multiple 1.7.0 builds


Return to “Development”

Who is online