Celestia 1.7.0 Development Thread

The place to discuss creating, porting and modifying Celestia's source code.
Topic author
onetwothree
Site Admin
Posts: 542
Joined: 22.09.2018
With us: 2 years 7 months

Post #961by onetwothree » 24.02.2021, 07:08

John Van Vliet wrote:this is the error
Sounds like an error recently fixed by Markerz. Could you update the master branch and recheck?

Markerz
Developer
Posts: 228
Joined: 29.01.2009
Age: 25
With us: 12 years 3 months
Location: Suzhou, China

Post #962by Markerz » 24.02.2021, 09:24

John Van Vliet wrote:this is the error
can you type `bt` here and enter, it should print a backtrace of the thread.

Avatar
cartrite
Posts: 1796
Joined: 15.09.2005
With us: 15 years 7 months
Location: Pocono Mountains, Pennsylvania, USA

Post #963by cartrite » 05.05.2021, 23:31

When eigen3 and fmt was removed it broke the build process.
Toshiba Satellite P875=S7200 laptop, Intel i5 processor 2.5 ghz 6 gb ram, Graphics Intel(R) HD Graphics 4000 openSUSE Leap 15.1 and soon to be 15.2

Topic author
onetwothree
Site Admin
Posts: 542
Joined: 22.09.2018
With us: 2 years 7 months

Post #964by onetwothree » 06.05.2021, 07:24

cartrite wrote:When eigen3 and fmt was removed it broke the build process.

What system do you use?

Avatar
cartrite
Posts: 1796
Joined: 15.09.2005
With us: 15 years 7 months
Location: Pocono Mountains, Pennsylvania, USA

Post #965by cartrite » Yesterday, 00:09

right now I running an "All in One" HP with windows 10 on the hard drive. Its's basically a monitor with a motherboard. A cheap one at that. But I'm running suse 15.2 on 2 external drives. A 4 Tib and an older 2 Tib. My original 1 Tib drive which runs suse 42.3 is where it fails. eigen 3.2 is installed but i did manage to also install eigen 3.3. It doesnt find it. I built celestia on the other 2 drive but this was prior to May 2 when eigen and fmt where removed. I haven't tried yet because of major issues getting linux to run on this new computer, My old Toshiba Satellite finnaly bit the dust. I haven't tried to build celestia on windows yet but I did install visual studio express 19.

Added after 5 minutes 24 seconds:
Markerz wrote:
John Van Vliet wrote:this is the error
can you type `bt` here and enter, it should print a backtrace of the thread.

John, your in China now?? :wink: I just noticed the info on your avatar box.

Added after 4 minutes 14 seconds:
oh sorry forget that john. I now realize that I was looking at Markerz info.

Should have known You got the penguin avatar
Toshiba Satellite P875=S7200 laptop, Intel i5 processor 2.5 ghz 6 gb ram, Graphics Intel(R) HD Graphics 4000 openSUSE Leap 15.1 and soon to be 15.2

Topic author
onetwothree
Site Admin
Posts: 542
Joined: 22.09.2018
With us: 2 years 7 months

Post #966by onetwothree » Today, 10:47

cartrite wrote:My original 1 Tib drive which runs suse 42.3 is where it fails. eigen 3.2 is installed but i did manage to also install eigen 3.3.

How did install Eigen3? I suppose you don't have FindEigen3.cmake installed (i've checked https://build.opensuse.org/package/view_file/open ... tall_FindEigen3.patch?expand=1). As Eigen is a header only library you can try to install it from 15.x (see https://build.opensuse.org/package/show/openSUSE:Backports:SLE-15/eigen3) or take file FindEigen3.cmake from eigen3 source package and put it into Celestia/cmake.


Return to “Development”

Who is online