Celestia 1.7.0 Development Thread

The place to discuss creating, porting and modifying Celestia's source code.
Topic author
onetwothree
Site Admin
Posts: 542
Joined: 22.09.2018
With us: 2 years 7 months

Post #961by onetwothree » 24.02.2021, 07:08

John Van Vliet wrote:this is the error
Sounds like an error recently fixed by Markerz. Could you update the master branch and recheck?

Markerz
Developer
Posts: 228
Joined: 29.01.2009
Age: 25
With us: 12 years 3 months
Location: Suzhou, China

Post #962by Markerz » 24.02.2021, 09:24

John Van Vliet wrote:this is the error
can you type `bt` here and enter, it should print a backtrace of the thread.

Avatar
cartrite
Posts: 1798
Joined: 15.09.2005
With us: 15 years 7 months
Location: Pocono Mountains, Pennsylvania, USA

Post #963by cartrite » 05.05.2021, 23:31

When eigen3 and fmt was removed it broke the build process.
Toshiba Satellite P875=S7200 laptop, Intel i5 processor 2.5 ghz 6 gb ram, Graphics Intel(R) HD Graphics 4000 openSUSE Leap 15.1 and soon to be 15.2

Topic author
onetwothree
Site Admin
Posts: 542
Joined: 22.09.2018
With us: 2 years 7 months

Post #964by onetwothree » 06.05.2021, 07:24

cartrite wrote:When eigen3 and fmt was removed it broke the build process.

What system do you use?

Avatar
cartrite
Posts: 1798
Joined: 15.09.2005
With us: 15 years 7 months
Location: Pocono Mountains, Pennsylvania, USA

Post #965by cartrite » 07.05.2021, 00:09

right now I running an "All in One" HP with windows 10 on the hard drive. Its's basically a monitor with a motherboard. A cheap one at that. But I'm running suse 15.2 on 2 external drives. A 4 Tib and an older 2 Tib. My original 1 Tib drive which runs suse 42.3 is where it fails. eigen 3.2 is installed but i did manage to also install eigen 3.3. It doesnt find it. I built celestia on the other 2 drive but this was prior to May 2 when eigen and fmt where removed. I haven't tried yet because of major issues getting linux to run on this new computer, My old Toshiba Satellite finnaly bit the dust. I haven't tried to build celestia on windows yet but I did install visual studio express 19.

Added after 5 minutes 24 seconds:
Markerz wrote:
John Van Vliet wrote:this is the error
can you type `bt` here and enter, it should print a backtrace of the thread.

John, your in China now?? :wink: I just noticed the info on your avatar box.

Added after 4 minutes 14 seconds:
oh sorry forget that john. I now realize that I was looking at Markerz info.

Should have known You got the penguin avatar
Toshiba Satellite P875=S7200 laptop, Intel i5 processor 2.5 ghz 6 gb ram, Graphics Intel(R) HD Graphics 4000 openSUSE Leap 15.1 and soon to be 15.2

Topic author
onetwothree
Site Admin
Posts: 542
Joined: 22.09.2018
With us: 2 years 7 months

Post #966by onetwothree » 08.05.2021, 10:47

cartrite wrote:My original 1 Tib drive which runs suse 42.3 is where it fails. eigen 3.2 is installed but i did manage to also install eigen 3.3.

How did install Eigen3? I suppose you don't have FindEigen3.cmake installed (i've checked https://build.opensuse.org/package/view_file/open ... tall_FindEigen3.patch?expand=1). As Eigen is a header only library you can try to install it from 15.x (see https://build.opensuse.org/package/show/openSUSE:Backports:SLE-15/eigen3) or take file FindEigen3.cmake from eigen3 source package and put it into Celestia/cmake.

Avatar
cartrite
Posts: 1798
Joined: 15.09.2005
With us: 15 years 7 months
Location: Pocono Mountains, Pennsylvania, USA

Post #967by cartrite » Yesterday, 00:53

I gave up for now installing celestia on 42.3 but I'm having another issue trying to build on windows 10 using vs 2019,

Code: Select all

winmain.obj : error LNK2001: unresolved external symbol "int debugVerbosity" (?debugVerbosity@@3HA) [C:\Celestia\Celest
ia\build\src\celestia\win32\celestia-win.vcxproj]
C:\Celestia\Celestia\build\src\celestia\win32\Debug\celestia-win.exe : fatal error LNK1120: 1 unresolved externals [C:\
Celestia\Celestia\build\src\celestia\win32\celestia-win.vcxproj]

Everything builds then that. :rambo: Anyhow 42.3 has long ago reached eol. I don't need to build celestia on that system. I only tried to restore it because that's the only linux system that was able to play tv I like shows on the internet. leap 15x cant. I'm gonna look into this link error and let you guys know if I get it working.
Toshiba Satellite P875=S7200 laptop, Intel i5 processor 2.5 ghz 6 gb ram, Graphics Intel(R) HD Graphics 4000 openSUSE Leap 15.1 and soon to be 15.2


Avatar
cartrite
Posts: 1798
Joined: 15.09.2005
With us: 15 years 7 months
Location: Pocono Mountains, Pennsylvania, USA

Post #969by cartrite » Yesterday, 08:26

I have Celestia built and running on my opensuse leap 15.2 systems. Thank you chandra but I'm not looking for a binary. Anyhow, I think I found the reason for the link error with windows. For some reason the file wglext.cpp fails to build. I get over a hundred errors from wglext.h. Undefined errors, syntax errors. For some reason the compiler quits trying to build that file after 100 errors and continues to build the rest of the files, then tries to link. First time that ever happened to me. Usually, the compiler quits after the first error. Don't know whats wrong with wglext.h yet tho. Must be missing something in MSVC. A portion of the terminal output.

Code: Select all

  wglext.cpp
C:\projects\Celestia\src\celestia\win32\wglext.h(311,16): error C2065: 'HPBUFFERARB': undeclared identifier [C:\project
s\Celestia\build\src\celestia\win32\celestia-win.vcxproj]
C:\projects\Celestia\src\celestia\win32\wglext.h(311,27): error C4430: missing type specifier - int assumed. Note: C++
does not support default-int [C:\projects\Celestia\build\src\celestia\win32\celestia-win.vcxproj]
C:\projects\Celestia\src\celestia\win32\wglext.h(314,16): error C2065: 'HPBUFFEREXT': undeclared identifier [C:\project
s\Celestia\build\src\celestia\win32\celestia-win.vcxproj]
C:\projects\Celestia\src\celestia\win32\wglext.h(314,27): error C4430: missing type specifier - int assumed. Note: C++
does not support default-int [C:\projects\Celestia\build\src\celestia\win32\celestia-win.vcxproj]
C:\projects\Celestia\src\celestia\win32\wglext.h(314,1): error C2374: 'DECLARE_HANDLE': redefinition; multiple initiali
zation [C:\projects\Celestia\build\src\celestia\win32\celestia-win.vcxproj]


Added after 3 hours 27 minutes:
Celestia 1.7.0 Development Thread
The main reason I still wanted to use suse 42.3 was that it was what I used with the Toshiba and it was able to play any video on the net. TV shows movies etc. But 42.3 running on this computer can't play them anyhow. Maybe some day I'll figure out the build issue but it's not a priority. Anyhow I did get Celestia to build on Windows. I had gles set to on. :silenced: I wasn't aware that windows 10 was supporting a decent Opengl. While running Celestia reports

Code: Select all

OpenGL Version: 4.6.148201 Compatibility Profile Context 20.50.02.04 27.20.15002.4001
Vendor: ATI Technologies Inc.
Renderer: AMD Radeon(TM) R3 Graphics
GLSL Version: 4.60
Max simultaneous textures: 8
Max texture size: 16384
Point size range: 1 - 63
Line width range: 1.000000 - 63.000000
Point size granularity: 0.12
Number of interpolators: 128
Max anisotropy filtering: 16.00
So I'm happy with that.

Added after 50 seconds:
I didn't build the QT version. I only built win32.
Toshiba Satellite P875=S7200 laptop, Intel i5 processor 2.5 ghz 6 gb ram, Graphics Intel(R) HD Graphics 4000 openSUSE Leap 15.1 and soon to be 15.2


Return to “Development”

Who is online