Page 2 of 2

Posted: 16.05.2018, 20:16
by Janus

Ra Dec is earth relative, so I can start getting my bearings looking at the sky.
I know this may sound weird, but I still can not find things based on RaDec, the math makes no sense to me.
Instead, I use tools such as Celestia to show me what is near it.

The only way I can do stuff so far is to visualize everyhting as relative to the position of HIP56.Kind of a silly thing, but it works for me.

Which command does your script crash on?


Posted: 16.05.2018, 21:00
by selden
A workaround for the VT resolution change is to set the TileSize specification in the associated .ctx file to half of the actual tile size.

Posted: 17.05.2018, 08:34
by FarGetaNik
Janus, with your intentions in mind, this makes more sense now.

Janus wrote:Which command does your script crash on?

It doesn't say exactly, but from what Celestia did and did not do, I can assume that the part that's a .cel script packed into a .celx command doesnt work at all. I have no experience in scripting and looking up some simple commands also didn't help and kept producing errors.

This part seems to work:

Code: Select all

-- start.celx

function CEL(source)
   local script = celestia:createcelscript(source)
   while script:tick() do

celestia:setlabelcolor("stars",         0.8, 0.7, 0.4)
celestia:setlabelcolor("planets",      0.0, 0.4, 1.0)
celestia:setlabelcolor("dwarfplanets",      0.3, 0.0, 0.9)
celestia:setlabelcolor("moons",         0.1, 0.6, 0.0)
celestia:setlabelcolor("minormoons",      0.0, 0.2, 0.0)
celestia:setlabelcolor("asteroids",      0.30, 0.21, 0.15)
celestia:setlabelcolor("comets",      0.0, 0.2, 0.3)
celestia:setlabelcolor("spacecraft",      0.2, 0.2, 0.2)

celestia:setlinecolor ("starorbits",      0.8, 0.7, 0.4)
celestia:setlinecolor ("planetorbits",      0.0, 0.4, 1.0)
celestia:setlinecolor ("dwarfplanetorbits",   0.2, 0.0, 0.5)
celestia:setlinecolor ("moonorbits",      0.1, 0.6, 0.0)
celestia:setlinecolor ("minormoonorbits",   0.0, 0.2, 0.0)
celestia:setlinecolor ("asteroidorbits",   0.21, 0.15, 0.10)
celestia:setlinecolor ("cometorbits",      0.0, 0.15, 0.2)
celestia:setlinecolor ("spacecraftorbits",   0.15, 0.15, 0.15)

and this seems to cause the crash:

Code: Select all

   select {object "Sol"}
   goto   {time 3.0 distance 6000}
   gotolonglat { time 3 distance 4000 longitude 0 latitude 50 }
   wait   {duration 3.0}

   print  {text "Welcome to Celestia!"  row -3  column 1  duration 3}

selden, oh so that's what this parameter is for. Have to try it. Thanks!

Posted: 17.05.2018, 14:56
by Janus

I have to admit that I have never used or tested the cel scripting stuff.
All my stuff is strictly celx, which makes far more sense to me, and is far more adaptable.

I am guessing here, but I believe it will have to do with my change of lua to 5.3.4 while updating other code.
I will go back and check my stuff, it is entirely possible that I missed something.
I will also see if I can figure out where CEL scripts are processed, about which I am currently clueless.

How is the performance?
I ask because it includes a number of changes, including sane loading order.
Basically, it loads everything in alphabetical order instead of at random, a change I made for selden as part of something else.


Added after 43 minutes 49 seconds:

Okay, it may have more to do with my typing skills than anything.
Still getting used to winmerge, when I used some different tools, I found a few places I have not updated properly.

Give these a try.

Removed: Please see post 34 instead.

They should fix the scripting glitches.
I am still in the process of removing checks for old lua versions mixed in the code.
I am putting the support libraries in the source tree in my fork, so I see no need to check their code versions.

I am getting closer to a mingw compile in windows using QT, then maybe just mingw by itself.
Long term goals, but this is a fun way to learn.


Posted: 17.05.2018, 15:48
by FarGetaNik
Janus wrote:All my stuff is strictly celx, which makes far more sense to me, and is far more adaptable.

Interestingly, the default start.cel script works just fine. The issue is the cel code in a celx script. I simply have no idea how to write simple commands in celx that do the same job as my cel script. That might be a tedious job for a boring weekend...

Janus wrote:How is the performance?
The performance is fine, but its hard to compare as I'm on new hardware now. To test it out, I launched 1.6 and 1.7 simultaniously and 1.7 seems to be just a tiny bit slower. Also when loading up a new planet it seems to be a bit slower (but that's really hard to actually test) so in terms of performance I don't really have anything major to complain about.

Posted: 17.05.2018, 15:55
by Goofy
Hi. I made a check of the starting time for Celestia 1.6.1 as installed, and the 1.7.0-112818, both with no addons or extras.
Here the results:
1.6.1: Earth shown in 8.53 seconds,
1.7.0: Earth shown in 13.24 seconds.
A notable 55% starting time increase.
Is it normal?

Moreover I cannot find the screen resolution settings, is it automatically set now?
Anyway I would like the possibility to change it at will, tuning it to the video projector resolution, if this is needed.
And, please, how can I choose to show or not the tool bar on top, so using the fullscreen?

Thank you.

Goofy :smile:

Posted: 17.05.2018, 16:16
by Janus

At least in the visual studio version that is under 'Render' => 'Select display mode' in the file menu bar. (Alt-R)
Supports secondary/tertiary display full screen, at least on my setup.
I use it with my projector when I am visualizing stuff, and others have used it for hand painting backdrops with accurate star fields.

Warning though, 16 bit color shown first, scroll down further for 32-bit color.
32-bit color is 24-bitRGB, with an optional perpixel alpha channel for blending.
But mostly it just makes calculating memory addresses easier, bit shifts are faster than multiplies.


Did the updated version fix the Cel glitch?


Posted: 17.05.2018, 17:26
by Goofy
Hi Janus.
No, nothing in the file menu bar "Render" window, and if I click Alt+R I can only read the actual texture resolution (Low-Medium-High), while in the 1.6.1 version it is correctly in the "Render" window.
Can it be fixed? :help:

And, I repeat, please can the toolbar be visible or not at will?
During cel (or celx) based projections it's very distracting, in my experience.
Thank you.

Goofy :smile:

Posted: 17.05.2018, 17:57
by Janus

Which OS & exact version are you using.
If you are using a visual studio version, Alt+R should look like this.

2018-05-17 10_38_11-Celestia.png

Which should then open up this.

2018-05-17 10_39_07-Celestia.png
2018-05-17 10_39_07-Celestia.png (37.34 KiB) Viewed 3141 times

Is yours different?

Perhaps something like this?

2018-05-17 10_46_30-Celestia.png

If it is like the latter, then to the best of my knowledge there is nothing you can do about the file bar at this time.
Instead, go back up a few posts to.
Removed: Please see post 34 instead.

2018-05-17 10_53_09-Celestia.png

Which is 1280x1024x32 off my tertiary monitor using the exe in the archive above.
I hope this helps.


Posted: 17.05.2018, 20:49
by FarGetaNik
Janus, no unfortunately not :sad:

Posted: 17.05.2018, 22:54
by Goofy
Hi Janus, thanks a lot for the quick reply.
I have Win 7 Pro x64, and the "view" windows is like the second one.
I tried the x64 version dated 180517, and now I have no more the buttos bar on top, can have the fullscreen, and again the possibility to choose the screen resolution.
Moreoiver, the starting time is 8.74 seconds, same as the 1.6.1 version. :clap:
Question: why the 281118 version is so different (and worse, IMHO)?
Thank you very much.

Goofy :smile:

Posted: 17.05.2018, 23:33
by Janus

I am glad it is working for you.
It sounds like you were using the QT version, which will always start slower.
Once I get my QT versions going again, more than likely they will be about as slow.
The reason for this is QT has a lot of overhead.
It is an entire eco system all on its own.

I have also made a number of tweaks in my code such as forcing alphabetical loading, and other minor changes.
The end result is something more predictable for the OS to respond to, especially if precaching is on. {SuperPreFetch which I always disable/remove}

You also need to remember that my code is not the main branch.
I have made tweaks that suit me, but not everyone may like.
I am working on a way to toggle the RaDec display, either by script or keycode.

If there is a specific tweak you need, let me know.
I will do something if I can.

I will be posting my updated code once I finish cleaning up my comments & documentation.


Posted: 18.05.2018, 10:15
by Goofy
Thank you Janus, very kind.
If any need will show up I'll contact you, surely.
Anyway, I like it as is.
I'll follow future news from you.
Bye and thank you once again.

Goofy :smile:

Posted: 21.05.2018, 07:23
by Janus

I believe I found the problem with the scripting.
I am attaching a recompile.
Please test and let me know if that fixed it.
I also updated with most of the latest from Commit 5350 to stay as in sync as I can.
There are some bits I did not use.
I may later, once I feel I understand why they did what they did.
Not rejecting it outright, just need to understand before using it.

Thanks for the testing.


Posted: 21.05.2018, 12:58
by FarGetaNik
Janus, it does work now! Thanks for your efforts! Now I can get fully started with Celestia :smoke: