fresnel effect and menu bug

Report bugs, bug fixes and workarounds here.
Topic author
marc
Posts: 426
Joined: 13.03.2002
With us: 18 years 7 months
Location: Outback Australia

fresnel effect and menu bug

Post #1by marc » 12.06.2002, 16:27

OS: Win2000
card: Geforce 2 MX400

This interesting effect happens to the cloud textures at very narrow FOV values. (1.2.4)
Image


Also on the CVS repositry the new style menus are not displaying any text when in full screen mode.
Image

chris
Site Admin
Posts: 4211
Joined: 28.01.2002
With us: 18 years 8 months
Location: Seattle, Washington, USA

Post #2by chris » 12.06.2002, 17:20

The problem with the cloud textures is due to z fighting--the cloud layer has slighly different coordinates than the planet surface. I must be setting the near clip plane incorrectly when the field of view is narrow . . . hopefully, this won't be too tricky to fix. Using GL's polygon offset may also help with this problem, though I'm not sure how well supported it is on all the cards out there.

The second problem . . . Clint? Any ideas? I have yet to try the menus myself in fullscreen mode, though I expect that the same bug will happen on my system.

--Chris

Avatar
t00fri
Developer
Posts: 8772
Joined: 29.03.2002
Age: 18
With us: 18 years 6 months
Location: Hamburg, Germany

fresnel effect and menu bug

Post #3by t00fri » 12.06.2002, 20:48

marc wrote:OS: Win2000
card: Geforce 2 MX400

This interesting effect happens to the cloud textures at very narrow FOV values. (1.2.4)


I am aware of the Newton interference rings at small fields since quite a while. Their origin I do not know, but if you switch off vertex /or/ pixel shaders the effect is gone...

I have quite a number of similar effects in "my private collection" but I did not want to "overload" Chris with all this for now;-)

My openGL know-how is still too superficial to seriously enter "therapy mode" here...

Bye Fridger


Return to “Bugs”

Who is online