configure: error: GLUT library version >= 3.7 not found

Report bugs, bug fixes and workarounds here.
Guest

configure: error: GLUT library version >= 3.7 not found

Post #1by Guest » 03.05.2002, 12:28

Sorryfor this second posting, but there are still Probs to compile celestia(1.2.4)...
Im using an 'old' SuSE 7.0 , with a self- compiled XFree 4.2 and a NVIDIA GeForce MX 2. I am using the recent Driver from NVidia and Mesa 4.02, compiled from source. Hardware Acceleration is working fine. Mesa-libs are located in /usr/lib, libglut is located in /usr/X11R6/lib.
"configure" celestia fails with
checking for X11/SM/SMlib.h... yes
checking for XpmFreeXpmImage in -lXpm... yes
checking for GL/gl.h... yes
checking for glNewList in -lGL... yes
checking for GL/glu.h... yes
checking for gluLookAt in -lGLU... yes
checking for GL/glut.h... yes
checking for glutKeyboardUpFunc in -lglut... no
configure: error: GLUT library version >= 3.7 not found

what am I doing wrong?

Guest

Post #2by Guest » 08.05.2002, 03:20

Use this patch:

Code: Select all

--- configure.orig      2002-03-27 22:08:29.000000000 -0500
+++ configure   2002-03-27 22:12:27.000000000 -0500
@@ -4087,7 +4087,7 @@
   echo $ac_n "(cached) $ac_c" 1>&6
 else
   ac_save_LIBS="$LIBS"
-LIBS="-lglut  $LIBS"
+LIBS="-lglut -lXi -lXmu -lXt $LIBS"
 cat > conftest.$ac_ext <<EOF
 #line 4093 "configure"
 #include "confdefs.h"
@@ -4121,7 +4121,7 @@
 #define $ac_tr_lib 1
 EOF
 
-  LIBS="-lglut $LIBS"
+  LIBS="-lglut -lXi -lXmu -lXt $LIBS"
 
 else
   echo "$ac_t""no" 1>&6

Guest

Post #3by Guest » 24.08.2002, 12:36

Hi.

When I try to apply the patch it gives me the following error;

Code: Select all

abri@hercules:~/downloads/apps/celestia/celestia-1.2.4$ patch configure patch.pat
patching file configure
patch: **** malformed patch at line 5: else

abri@hercules:~/downloads/apps/celestia/celestia-1.2.4$


Please help,, I miss celestia
:(

Thanks
RefriedBean


Return to “Bugs”

Who is online