Automatic traver nowhere (BigSurem M1)

Report bugs, bug fixes and workarounds here.
Topic author
stalubalub
Posts: 5
Joined: 31.03.2021
With us: 1 month 9 days

Automatic traver nowhere (BigSurem M1)

Post #1by stalubalub » 04.04.2021, 09:02

Hello,

I start Celestia 1.6.2 on my M1 MacPro with BigSure.
When I manipulate time (faster, slower, forward, back) travel through space begins. When I press S to stop it, it stops (speed is going to 0), but in this same time is accelerating again.

I have to quit and start again to stop this process.

Please help me solve this problem.
Regards
Lukasz

Markerz
Developer
Posts: 228
Joined: 29.01.2009
Age: 25
With us: 12 years 3 months
Location: Suzhou, China

Post #2by Markerz » 05.04.2021, 08:09

can you describe the steps in detail to reproduce it?

Topic author
stalubalub
Posts: 5
Joined: 31.03.2021
With us: 1 month 9 days

Post #3by stalubalub » 09.04.2021, 20:33

Sure.

Start and set up Solar system like this:

view on the Sun, from behind the Earth
https://prnt.sc/118fqxp

Speedup time x10 x100 x1000 x10000
and travel forward starts:

https://prnt.sc/118frux


Next I can Go to Select Object Cmd+L -> Sun and click GO. Sun is on my screen and in few second travel begins again
https://prnt.sc/118ftmr

and movie:
https://we.tl/t-Zuzrm9yo3i

Regards
Lukasz

Markerz
Developer
Posts: 228
Joined: 29.01.2009
Age: 25
With us: 12 years 3 months
Location: Suzhou, China

Post #4by Markerz » 10.04.2021, 01:22

stalubalub wrote:and travel forward starts:
I wonder why the speed is always increasing, can you try if the build on App Store works? https://apps.apple.com/us/app/id1483317223

Topic author
stalubalub
Posts: 5
Joined: 31.03.2021
With us: 1 month 9 days

Post #5by stalubalub » 10.04.2021, 12:39

unfortunately this same behaviour :-(

https://we.tl/t-uZlodugEAX

Ł

Markerz
Developer
Posts: 228
Joined: 29.01.2009
Age: 25
With us: 12 years 3 months
Location: Suzhou, China

Post #6by Markerz » 10.04.2021, 13:53

what key strokes did you use exactly? so far as I see the speed keeps increasing.

Topic author
stalubalub
Posts: 5
Joined: 31.03.2021
With us: 1 month 9 days

Post #7by stalubalub » 12.04.2021, 15:43

When I set Sun, Earth, Moon using control keys and mouse nothing wrong its happened.
Then I'm pressing "L" (following documentation to increase or decrease speed) and after few seconds travel starts.
I probably discovered what could be wrong. I have one keystroke in system hidden by lll (small L letter).
When I press:
"LLL" and more - everything is fine,
"llkllkllkllk" - OK,
"lll" - after ~ 6 sec. speed increasing starts
"ll" wait ~20sec "l" - after ~ 6 sec. speed increasing starts

I have this keystroke sience 10.7 "Lion" and I can't remember what Celestia version was in that time, but I didn't noticed such a kind behaviour.

"lll" - lukasz.stachowiak@gmail.com, when I changed it for example on "ll." Celestia goes fine.

Hope it helps

Markerz
Developer
Posts: 228
Joined: 29.01.2009
Age: 25
With us: 12 years 3 months
Location: Suzhou, China

Post #8by Markerz » 13.04.2021, 14:58

well, the speed increases with the A key, by looking at your video, it seems somehow that triggers A key to be always pressed.

Topic author
stalubalub
Posts: 5
Joined: 31.03.2021
With us: 1 month 9 days

Post #9by stalubalub » 30.04.2021, 08:14

… and even after stops the travel begins again and speed increases again.
I don't know why it's happened. When I changed key-combo described above, program returns to normal.
BTW. This combo I have sience Lion 10.7 with Celestia and now this issue starts.

regards
Ł


Return to “Bugs”

Who is online