clicking a emptey part of space randomly crashes celestia

Report bugs, bug fixes and workarounds here.
Avatar
Topic author
trappistplanets
Posts: 406
Joined: 11.06.2020
With us: 1 year

Post #21by trappistplanets » 05.01.2021, 12:39

Gurren Lagann wrote:He uses a Windows 7 PC with Celestia 1.6.x, and he doesnt use Lua Tools.
is there somthing about the Lua tools that i should get them?
and how does Lua Tools relate to my crashing issue

Avatar
SevenSpheres
Moderator
Posts: 581
Joined: 08.10.2019
With us: 1 year 8 months

Post #22by SevenSpheres » 05.01.2021, 16:50

trappistplanets wrote:is there somthing about the Lua tools that i should get them?
and how does Lua Tools relate to my crashing issue

Nevermind Lua Tools, do this:

SevenSpheres wrote:Try removing all dsc addons from your extras folder, then adding them back one by one to see which one causes the crash.
john71 wrote:You have to add one add-on at a time and try to crash Celestia. Start with an empty extras folder.
My Addons: viewtopic.php?f=23&t=19978 • Contributing to development as much as I can occasionally • Discord server admin
PC specs: HP desktop, Windows 10 Home 64-bit, Intel Core i7-7700 (3.60 GHz), 16 GB RAM, 1 TB HDD + 128 GB SSD, Intel HD Graphics 630
Celestia versions: 1.5.1, 1.6.1, 1.6.2 (primary), 1.7.0 (latest build + some older ones)

Avatar
Topic author
trappistplanets
Posts: 406
Joined: 11.06.2020
With us: 1 year

Post #23by trappistplanets » 26.03.2021, 13:22

funny... the bug is now not happening to me anymore
idk what fixed it but i am happy its not happening anymore, it was annoying

Avatar
SevenSpheres
Moderator
Posts: 581
Joined: 08.10.2019
With us: 1 year 8 months

Post #24by SevenSpheres » 01.05.2021, 20:14

Update: nussun recently had this same issue, which turned out to be caused by this addon. I guessed that she hadn't put the "blank.png" custom template in the main "models" folder, which turned out to be correct. Given this and the cause of my issue months ago, it seems that this issue is caused by missing or incorrect custom templates.

This also reminds me that I need to release my Lua version of the elliptical galaxies addon, which doesn't use a custom template...
My Addons: viewtopic.php?f=23&t=19978 • Contributing to development as much as I can occasionally • Discord server admin
PC specs: HP desktop, Windows 10 Home 64-bit, Intel Core i7-7700 (3.60 GHz), 16 GB RAM, 1 TB HDD + 128 GB SSD, Intel HD Graphics 630
Celestia versions: 1.5.1, 1.6.1, 1.6.2 (primary), 1.7.0 (latest build + some older ones)

Avatar
Topic author
trappistplanets
Posts: 406
Joined: 11.06.2020
With us: 1 year

Post #25by trappistplanets » 03.05.2021, 10:35

this bug suddenly dissapeared


Return to “Bugs”

Who is online