Moons locations

Report bugs, bug fixes and workarounds here.
Topic author
maatkai
Posts: 8
Joined: 14.01.2010
With us: 9 years 7 months

Moons locations

Post #1by maatkai » 25.01.2010, 21:06

Hello everyone,

I don't know if it's really a bug, but i have a little problem with moons locations.
All others locations on planets, asteroids and saturn rings are displaying ok but there is no locations on any moon. I use the last build of celestia's sources and the problem doesn't appear on the "official" version 1.6.

Of course, i checked the config file, try some stuffs like comment the locs files which don't work and copy the files in "extra" directory. I use also LuaEduTools and i use to comment a part in AddonBox which concern the locations to use the "&" shortcut, but even if i remove LuaEduTools from "extras" i have NO locations on moons.

So now, i don't really understand.

Anyone has an idea?

Cyril

Avatar
t00fri
Developer
Posts: 8772
Joined: 29.03.2002
Age: 17
With us: 17 years 4 months
Location: Hamburg, Germany

Re: Moons locations

Post #2by t00fri » 25.01.2010, 21:17

maatkai wrote:Hello everyone,

I don't know if it's really a bug, but i have a little problem with moons locations.
All others locations on planets, asteroids and saturn rings are displaying ok but there is no locations on any moon. I use the last build of celestia's sources and the problem doesn't appear on the "official" version 1.6.

Of course, i checked the config file, try some stuffs like comment the locs files which don't work and copy the files in "extra" directory. I use also LuaEduTools and i use to comment a part in AddonBox which concern the locations to use the "&" shortcut, but even if i remove LuaEduTools from "extras" i have NO locations on moons.

So now, i don't really understand.

Anyone has an idea?

Cyril

Cyril,

certainly not a bug.

First, check whether you have all required location files for moons correctly installed in the Celestia data/ directory.

Earth Moon:
moon_locs.ssc

Mars moons:
marsmoons_locs.ssc

Jupiter moons
jupitermoons_locs.ssc

Saturn moons
saturnmoons_locs.ssc

Uranus moons
uranusmoons_locs.ssc

Neptun moons
neptunemoons_locs.ssc

Then make sure that the location display is activated!
It works perfectly for me on all OS. My statement however applies only for the official Celestia distribution. Any add-ons or Lua-edu stuff may in principle cause incorrect behaviour about which I have no opinion.

Fridger
Image

Topic author
maatkai
Posts: 8
Joined: 14.01.2010
With us: 9 years 7 months

Re: Moons locations

Post #3by maatkai » 25.01.2010, 23:32

Fridger, thank you to answer,

Of course, the first thing i did was to check the files and see if there are no typo, and if they are well defined in celestia.cfg .

I think LuaEdu is not concern here, because when i remove it, the "bug" is still here. And when i put LuaEdutools in a "clean" version of celestia (with no addons at all, base package), there is no such bug.

What i really don't understand is why i have all the other locations (on earth, venus ,mars ,ida, eros etc...) , but none on the moons, and only the moons... weird!

Cyril

EDIT -> Finally i find! I have separated ssc files for the moons and a "customize" solarsys.ssc and i put usually the moons files in the extra directory. I try to copy the moons ssc files in "data" directory and to define them in the config file... et voil?! It works fine!
What it's still weird, it's that i have also separated files for asteroids which are in extra directory and i had no such bugs with them...

Avatar
t00fri
Developer
Posts: 8772
Joined: 29.03.2002
Age: 17
With us: 17 years 4 months
Location: Hamburg, Germany

Re: Moons locations

Post #4by t00fri » 26.01.2010, 01:49

Cyril,

good to read that you found the solution of your problem.

Note that we did quite some reordering of data files for 1.6 final, notably also the *_locs.ssc files! So it's always improtant to do a fresh install with all data files after a new version has come out. In particular it will not work to just replace an earlier executable by the 1.6.final one.

Fridger
Image


Return to “Bugs”

Who is online

Users browsing this forum: 1 guest