[bug] 4898.exe BETA ^^ 1.6.1 version

Report bugs, bug fixes and workarounds here.
Topic author
symaski62
Posts: 602
Joined: 01.05.2004
Age: 36
With us: 15 years 3 months
Location: france, divion

[bug] 4898.exe BETA ^^ 1.6.1 version

Post #1by symaski62 » 31.10.2009, 11:20

vista home basic
intel(R) Pentium(R) Dual CPU E2160 @ 1,80GHz 1,79GHz
1Go RAM
NVIDIA GeForce 8400 GS
directX 11
celestia 1.6
with a general handicap of 80% and it makes much d' efforts for the community and s' expimer, thank you d' to be understanding.

Vincent
Posts: 1356
Joined: 07.01.2005
With us: 14 years 7 months
Location: Nancy, France

Re: [bug] 4898.exe BETA ^^ 1.6.1 version

Post #2by Vincent » 31.10.2009, 11:36

symaski62,

Could you please precise a bit further what kind of bug you're having on your system?
Here's a screenshot of what I get on mine with your URL (version 1.6.1 revision 4898).

Peux-tu STP pr?ciser quel type de bug tu rencontres avec ton syst?me ?
Voici une capture d'?cran de ce que j'obtiens sur le mien avec ton URL (version 1.6.1 revision 4898).
@+
Vincent

Celestia Qt4 SVN / Celestia 1.6.1 + Lua Edu Tools v1.2
GeForce 8600 GT 1024MB / AMD Athlon 64 Dual Core / 4Go DDR2 / XP SP3

Topic author
symaski62
Posts: 602
Joined: 01.05.2004
Age: 36
With us: 15 years 3 months
Location: france, divion

Re: [bug] 4898.exe BETA ^^ 1.6.1 version

Post #3by symaski62 » 31.10.2009, 14:30

:wink: orbiter lune hum :)
vista home basic
intel(R) Pentium(R) Dual CPU E2160 @ 1,80GHz 1,79GHz
1Go RAM
NVIDIA GeForce 8400 GS
directX 11
celestia 1.6
with a general handicap of 80% and it makes much d' efforts for the community and s' expimer, thank you d' to be understanding.

Avatar
selden
Developer
Posts: 10063
Joined: 04.09.2002
With us: 16 years 11 months
Location: NY, USA

Re: [bug] 4898.exe BETA ^^ 1.6.1 version

Post #4by selden » 31.10.2009, 14:57

I managed to reproduce the problem.

To describe the problem slightly differently:
The state of the flag "render orbits for moons" is not included in the Cel URL.
(and I fear there may be other render flags which are missing. :( )

To reproduce the problem:
Select the menu option Render / View Options / Orbits / Moons
view the moon's orbit path
save that url to a file
select the url
The moon's orbit path continues to be drawn

de-select the menu option Render / View Options / Orbits / Moons
the moon's orbit path is not drawn
select the url
the moon's orbit path is still *not* drawn.
It should be.
Selden

Topic author
symaski62
Posts: 602
Joined: 01.05.2004
Age: 36
With us: 15 years 3 months
Location: france, divion

Re: [bug] 4898.exe BETA ^^ 1.6.1 version

Post #5by symaski62 » 31.10.2009, 15:09

ROHHHH :) image noob !
vista home basic
intel(R) Pentium(R) Dual CPU E2160 @ 1,80GHz 1,79GHz
1Go RAM
NVIDIA GeForce 8400 GS
directX 11
celestia 1.6
with a general handicap of 80% and it makes much d' efforts for the community and s' expimer, thank you d' to be understanding.

Avatar
selden
Developer
Posts: 10063
Joined: 04.09.2002
With us: 16 years 11 months
Location: NY, USA

Re: [bug] 4898.exe BETA ^^ 1.6.1 version

Post #6by selden » 31.10.2009, 15:19

Right.

The new orbit rendering code still has bugs.

Highly eccentric orbits are not drawn correctly: they don't go around the parent body.
There also are some strange bumps in their paths.

Chris is working on it.
Selden


Return to “Bugs”

Who is online

Users browsing this forum: 4 guests