celestia crashes when i turn on orbits around 43 com ( real known star)

Report bugs, bug fixes and workarounds here.
Avatar
Topic author
trappistplanets
Posts: 400
Joined: 11.06.2020
With us: 1 year

celestia crashes when i turn on orbits around 43 com ( real known star)

Post #1by trappistplanets » 19.05.2021, 13:44

i made a 3 planet system around the star known as 43 com in celestia and each time i turn on orbits the dam thing crashes
why is this happening?
is there a fix to this?
what is going on?
it didn't do this before i added planet 3 to the system
code for planet 3 (in case its a code issues that is messing with orbits that is causing the crash)

Code: Select all

"Kikimora" "43 Com"
{
   Class      "planet"
   Texture      "Kikimora.*"
   Radius      2506
   BumpMap      "Kikimora-bump.*"
   BumpHeight   0.7
   Albedo      0.71
   LunarLambert   0.7
   
   Atmosphere
   {
      Height      1000
        Mie              0.0003
        MieAsymmetry     -0.55
      MieScaleHeight   110
      Rayleigh   [ 0.024 0.0011 0.005 ]
      Absorption   [ 0.0007 0.060 0.009 ]
   }

   EllipticalOrbit
   {
      Period      1171      #years
      SemiMajorAxis   114
      Eccentricity     0.92
      Inclination    60.6
      ArgOfPericenter    272
   }

   UniformRotation
   {
      Period        31.25
      Inclination    5.2152
   }
}


help me stop the crashing please
it doesn't do this around the solar system with has 8 planets and many dwarf planets and asteroids when i turn on orbits

Added after 2 minutes 6 seconds:
i am using Celestia EP btw

Added after 4 minutes 8 seconds:
i am able to get this close to the system to faintly see Kikimora's orbit before the thing crashes
Untitled.png


Untitled2.png
zoomed in pic
Untitled2.png (4.39 KiB) Viewed 1270 times

Avatar
SevenSpheres
Moderator
Posts: 579
Joined: 08.10.2019
With us: 1 year 8 months

Post #2by SevenSpheres » 19.05.2021, 14:45

It works for me.
kikimora.png
My Addons: viewtopic.php?f=23&t=19978 • Contributing to development as much as I can occasionally • Discord server admin
PC specs: HP desktop, Windows 10 Home 64-bit, Intel Core i7-7700 (3.60 GHz), 16 GB RAM, 1 TB HDD + 128 GB SSD, Intel HD Graphics 630
Celestia versions: 1.5.1, 1.6.1, 1.6.2 (primary), 1.7.0 (latest build + some older ones)

Avatar
Topic author
trappistplanets
Posts: 400
Joined: 11.06.2020
With us: 1 year

Post #3by trappistplanets » 19.05.2021, 17:57

odd
hmmm..

Avatar
Anthony_B_Russo10
Moderator
Posts: 567
Joined: 03.07.2018
Age: 18
With us: 2 years 11 months
Location: Tallahassee, Florida, US

Post #4by Anthony_B_Russo10 » 19.05.2021, 21:29

Your computer must have issues Trappist, since I have only seen Celestia crash from orbits is when thee are too many on screen.
Anthony B. Russo, I like Pluto. Mod of the Celestia subreddit: https://www.reddit.com/r/Celestiasoftware/
I have over 30 computers, trying to list them here would be a pain.


Return to “Bugs”

Who is online