Error on the Celestial Matters website

General discussion about Celestia that doesn't fit into other forums.
Avatar
Topic author
SpaceFanatic64
Posts: 401
Joined: 16.08.2018
Age: 14
With us: 1 year 6 months
Location: Southern California

Error on the Celestial Matters website

Post #1by SpaceFanatic64 » 05.09.2019, 01:10

While I was browsing Celestial Matters today, I found this error on the main page.
warning: preg_replace_callback(): Requires argument 2, '_decode_entities("$1", "$2", "$0", $newtable, $exclude)', to be a valid callback in /public/vhost/c/cm/html/includes/unicode.inc on line 345.
warning: preg_replace_callback(): Requires argument 2, '_decode_entities("$1", "$2", "$0", $newtable, $exclude)', to be a valid callback in /public/vhost/c/cm/html/includes/unicode.inc on line 345.
warning: preg_replace_callback(): Requires argument 2, '_decode_entities("$1", "$2", "$0", $newtable, $exclude)', to be a valid callback in /public/vhost/c/cm/html/includes/unicode.inc on line 345.
warning: preg_replace_callback(): Requires argument 2, '_decode_entities("$1", "$2", "$0", $newtable, $exclude)', to be a valid callback in /public/vhost/c/cm/html/includes/unicode.inc on line 345.
warning: preg_replace_callback(): Requires argument 2, '_decode_entities("$1", "$2", "$0", $newtable, $exclude)', to be a valid callback in /public/vhost/c/cm/html/includes/unicode.inc on line 345.
warning: preg_replace_callback(): Requires argument 2, '_decode_entities("$1", "$2", "$0", $newtable, $exclude)', to be a valid callback in /public/vhost/c/cm/html/includes/unicode.inc on line 345.
warning: preg_replace_callback(): Requires argument 2, '_decode_entities("$1", "$2", "$0", $newtable, $exclude)', to be a valid callback in /public/vhost/c/cm/html/includes/unicode.inc on line 345.
warning: preg_replace_callback(): Requires argument 2, '_decode_entities("$1", "$2", "$0", $newtable, $exclude)', to be a valid callback in /public/vhost/c/cm/html/includes/unicode.inc on line 345.
warning: preg_replace_callback(): Requires argument 2, '_decode_entities("$1", "$2", "$0", $newtable, $exclude)', to be a valid callback in /public/vhost/c/cm/html/includes/unicode.inc on line 345.
Other than that, the website is still functional, but I don't understand any of this. Could anyone care to give an explanation on what this is?
Follower of the "Celestia Origin" project
Graphics Card: ATI Radeon 3000 Graphics

Avatar
Anthony_B_Russo10
Posts: 363
Joined: 03.07.2018
Age: 17
With us: 1 year 7 months
Location: Tallahassee, Florida, US

Post #2by Anthony_B_Russo10 » 05.09.2019, 02:21

It maybe an HTML error.
Anthony B. Russo, I like Pluto. Mod of the Celestia subreddit: https://www.reddit.com/r/Celestiasoftware/
Dell Latitude D820 D400 D410 D420 6520 D610 D505, Acer Aspire, Dell Optiplex 745 x2 755 GX-620 960, Sony Vaio PCG-F420, Packard Bell Legend 100, HP Compaq, IBM clone, IBM ThinkPad, MacBook Pro

pirogronian
Developer
Posts: 210
Joined: 05.01.2018
Age: 34
With us: 2 years 1 month
Location: Wrocław
Contact:

Post #3by pirogronian » 05.09.2019, 07:25

It looks like PHP error. Maybe hosting administrator updated its software, which new version deprecate some code used currently by Celestial Matters.

Avatar
LukeCEL
Posts: 230
Joined: 26.09.2017
With us: 2 years 5 months

Post #4by LukeCEL » 05.09.2019, 16:28

I think that error has been on the main page for quite some time now. However, the forums still work fine.

Avatar
Joey P. M
Posts: 398
Joined: 28.10.2017
Age: 17
With us: 2 years 3 months
Location: Vladivostok, Russia

Post #5by Joey P. » 05.09.2019, 22:24

I haven't registered on the Celestial Matters website, but is it still active?
Joey P.


Return to “Celestia Users”

Who is online