internal timing weirdness

Have a question about using Celestia? Check here first for FAQs and helpful advice.
Forum rules
Please help to make this forum more useful by checking the FAQs before posting! Keep it clean, keep it civil, keep it truthful, stay on topic, be responsible, share your knowledge.
Topic author
Fizz
Posts: 9
Joined: 10.09.2019
With us: 1 month 5 days

internal timing weirdness

Post #1by Fizz » 30.09.2019, 16:00

Hi all-

A week or so ago the community helped me get Celestia 1.7 running on Linux. For the most part, things are working well, but i've come across a curious issue.

Something seems messed up with the time. If i'm running Celestia on screen and let it go for hours on end, it stays synced. But if i'm working on a different workspace, the time inside Celestia is sped up. To try to quantify this, i put Celestia on real time, and let it run for 3 hours. After 3 hours, the Celestia clock was the correct 3 hours ahead from when i started. But this time I switched to another workspace, and waited for 3 hours. When i came back, Celestia was not 3 hours ahead of when i left, but an additional 2 hours 9.5 minutes ahead. In the 3 hours of real time i was away, Celestia's internal time had advanced 5 hours 9.5 minutes.

So something about being on another workspace is causing the Celestia internal clock to speed up significantly. Not sure if anything can be done about this, but at worst i figure it's something to put to the developers for the next version.


-Fizz

onetwothree
Developer
Posts: 309
Joined: 22.09.2018
With us: 1 year

Post #2by onetwothree » 30.09.2019, 18:20

Quite interesting. We will check this.

Topic author
Fizz
Posts: 9
Joined: 10.09.2019
With us: 1 month 5 days

Post #3by Fizz » 01.10.2019, 18:53

I did another test overnight. I started at 11:28pm with Celestia time synced to my system time. I checked this morning at 7:48am. The system time was of course correct, but Celestia time was 11:31am, so nearly 4 hours ahead.

I also confirmed that this only occurs when Celestia is running in a non-active workspace. So it's not a screensaver issue or something like that.

Otherwise, the only quirk i've seen is the spacecraft listing around Earth is doubled- all spacecraft are listed twice.

-Fizz


Return to “Help Central”

Who is online

Users browsing this forum: 8 guests
Bots: Google [Bot]