Render issues

Have a question about using Celestia? Check here first for FAQs and helpful advice.
Forum rules
Please help to make this forum more useful by checking the FAQs before posting! Keep it clean, keep it civil, keep it truthful, stay on topic, be responsible, share your knowledge.
Avatar
Topic author
Anthony_B_Russo10
Posts: 271
Joined: 03.07.2018
Age: 16
With us: 1 year 4 months
Location: Tallahassee, Florida, US

Render issues

Post #1by Anthony_B_Russo10 » 07.10.2018, 05:11

Does anyone know how to fix all of any of the issues I'm having with Celestia's bump maps, spec maps, stratospheric scattering, and ring shadows not rendering despite being selected to render. (see images below)
2018-10-07 (4).png
2018-10-07 (3).png
2018-10-07 (2).png
2018-10-07 (1).png
Anthony B. Russo, I like Pluto. Mod of the Celestia subreddit: https://www.reddit.com/r/Celestiasoftware/
Dell Latitude D820 D400 D410 D420 6520 D610, Acer Aspire, Dell Optiplex 745 x2 755 GX-620 960, Sony Vaio PCG-F420, Packard Bell Legend 100, HP Compaq, IBM clone, IBM ThinkPad, MacBook Pro

Avatar
gironde M
Posts: 409
Joined: 16.12.2016
Age: 67
With us: 2 years 11 months
Location: Montigny-Les-Metz, Grand Est, Lorraine, Moselle, France

Post #2by gironde » 07.10.2018, 08:44

To begin with, you need to make sure that you have the corresponding textures and that they are placed in the right place compared to the ssc file that defines them. Either they are in the textures directory in the Celestia collection or they are in the extras directory close to the ssc file (at the same level). Otherwise, celestial can't find them.

:hi:

Avatar
Topic author
Anthony_B_Russo10
Posts: 271
Joined: 03.07.2018
Age: 16
With us: 1 year 4 months
Location: Tallahassee, Florida, US

Post #3by Anthony_B_Russo10 » 07.10.2018, 16:33

All of the textures are in correct folder, it’s just that the program won’t render them period. I have also tried uninstalling and reinstalling Celestia to fix it, but it did not work.
Anthony B. Russo, I like Pluto. Mod of the Celestia subreddit: https://www.reddit.com/r/Celestiasoftware/
Dell Latitude D820 D400 D410 D420 6520 D610, Acer Aspire, Dell Optiplex 745 x2 755 GX-620 960, Sony Vaio PCG-F420, Packard Bell Legend 100, HP Compaq, IBM clone, IBM ThinkPad, MacBook Pro

Avatar
selden
Developer
Posts: 10069
Joined: 04.09.2002
With us: 17 years 2 months
Location: NY, USA

Post #4by selden » 07.10.2018, 19:57

Celestia's console log usually provides hints as to what might be going wrong.

Type a tilde (~) to see the console log while Celestia is running.
If your keyboard locale supports diacritical marks, you'll probably have to type a space first.

Use the up- and down- arrow keys to navigate in the log.
Selden

Avatar
Topic author
Anthony_B_Russo10
Posts: 271
Joined: 03.07.2018
Age: 16
With us: 1 year 4 months
Location: Tallahassee, Florida, US

Post #5by Anthony_B_Russo10 » 07.10.2018, 20:00

Ok, because this issue is happening across all of my computers.

Added after 3 hours 26 minutes:
Which drop down would the console log be under?
Anthony B. Russo, I like Pluto. Mod of the Celestia subreddit: https://www.reddit.com/r/Celestiasoftware/
Dell Latitude D820 D400 D410 D420 6520 D610, Acer Aspire, Dell Optiplex 745 x2 755 GX-620 960, Sony Vaio PCG-F420, Packard Bell Legend 100, HP Compaq, IBM clone, IBM ThinkPad, MacBook Pro

Avatar
selden
Developer
Posts: 10069
Joined: 04.09.2002
With us: 17 years 2 months
Location: NY, USA

Post #6by selden » 08.10.2018, 14:44

Celestia's console log appears as white text at the lower left of Celestia's main graphics window. It's not a separate popup window.

Also, if you're loading many or complex addons, you probably will need to make its buffer larger.
Edit Celestia's startup file celestia.cfg so that the line
# LogSize 1000
becomes
LogSize 10000
Selden

Avatar
Topic author
Anthony_B_Russo10
Posts: 271
Joined: 03.07.2018
Age: 16
With us: 1 year 4 months
Location: Tallahassee, Florida, US

Post #7by Anthony_B_Russo10 » 09.10.2018, 01:56

I managed to figure out what caused most of the problems, my OpenGL render path was set to basic,
Gas Giant.png

although the atmospheric scattering is still broken.
Earth 2.png
Anthony B. Russo, I like Pluto. Mod of the Celestia subreddit: https://www.reddit.com/r/Celestiasoftware/
Dell Latitude D820 D400 D410 D420 6520 D610, Acer Aspire, Dell Optiplex 745 x2 755 GX-620 960, Sony Vaio PCG-F420, Packard Bell Legend 100, HP Compaq, IBM clone, IBM ThinkPad, MacBook Pro


Return to “Help Central”

Who is online