celestia 1.7.0

Have a question about using Celestia? Check here first for FAQs and helpful advice.
Forum rules
Please help to make this forum more useful by checking the FAQs before posting! Keep it clean, keep it civil, keep it truthful, stay on topic, be responsible, share your knowledge.
Topic author
themartian
Posts: 25
Joined: 16.08.2017
Age: 14
With us: 1 year 3 months

celestia 1.7.0

Post #1by themartian » 16.08.2017, 21:28

well, i have downloaded the x64 of 1.7, but my pc needs the 32 bits version, does anyone knows where i can find it? :help:

thank you and sotry for my bad english but i'm native spanishspeaking :sad:

john71
Posts: 327
Joined: 10.08.2016
With us: 2 years 3 months

Post #2by john71 » 18.08.2017, 07:38

https://apps.alexell.ru/celestia/bin/

https://apps.alexell.ru/celestia/bin/x86/

https://apps.alexell.ru/celestia/new-dll/

Added after 1 minute 4 seconds:
Old 32 bit 1.6.1 version: https://sourceforge.net/projects/celestia/files/Celestia-win32-bin/1.6.1/celestia-win32-1.6.1.exe/download

Added after 5 minutes 14 seconds:
First install the old version, then copy to the main Celestia folder the new exe and dll files.

Topic author
themartian
Posts: 25
Joined: 16.08.2017
Age: 14
With us: 1 year 3 months

Post #3by themartian » 19.08.2017, 04:43

it says i need a vcruntime.dll file that doesn't exists on my pc :pray:

john71
Posts: 327
Joined: 10.08.2016
With us: 2 years 3 months

Post #4by john71 » 19.08.2017, 06:59

1.) Remove the fmod.dll and the 32 bit 1.7 dev7 exe file
2.) reinstall Celestia 1.6.1 again.
3.) run the 1.6.1 exe file.

Topic author
themartian
Posts: 25
Joined: 16.08.2017
Age: 14
With us: 1 year 3 months

Post #5by themartian » 19.08.2017, 21:20

i will see if that works, but if it don't work then idk what more to do, and if it works i hope it don't says i need something of opengl 5.0

Avatar
roninwolf1981
Posts: 26
Joined: 23.02.2017
Age: 37
With us: 1 year 8 months
Location: Bastrop, TX

Post #6by roninwolf1981 » 06.05.2018, 19:14

@themartian

Well, did it work?
With the first link, the chain is forged. The first speech censured, the first thought forbidden, the first freedom denied...chains us all irrevocably.

Topic author
themartian
Posts: 25
Joined: 16.08.2017
Age: 14
With us: 1 year 3 months

Post #7by themartian » 18.06.2018, 16:12

sorry for repling late, i was a lil busy, nope it didn't work :cry:

Janus
Posts: 216
Joined: 13.08.2016
With us: 2 years 3 months

Post #8by Janus » 18.06.2018, 19:35

A note here for people trying the current builds.

Alexell's releases for win32/64 all require the VS2017 runtimes to be installed.
They also require all of the QT DLL files as well.
If you do not have the runtimes in particular, and be sure to match the x86 vs x64 versions, it will give you errors.


Janus.

Avatar
CM1215 M
Posts: 158
Joined: 30.08.2017
Age: 16
With us: 1 year 2 months
Location: Ohio, U. S. A.

Post #9by CM1215 » 20.06.2018, 12:59

I installed the latest VS2017 runtime for x64 to run the latest Celestia 1.7.0 for x64, but when I try to load it up, it freezes at 100% files loaded. I get no error message, no warning, it just sits there and builds up memory usage.

I've also discovered that my indev 7 version of 1.7.0, which has been working for me for a long time, suddenly stopped working. For some reason, it freezes when it tries to load stars.dat. It also sits there and builds up memory usage.

I suspect some random Windows update is to blame for this...
CM1215: Celestial master in learning.

Avatar
gironde M
Posts: 301
Joined: 16.12.2016
Age: 66
With us: 1 year 11 months
Location: Montigny-Les-Metz, Grand Est, Lorraine, Moselle, France

Post #10by gironde » 21.06.2018, 07:36

I have the same symptoms and after a while the loading image disappears.

:sad:


Return to “Help Central”

Who is online

Users browsing this forum: 4 guests