Lua_Edu_Tools_1.2beta8.zip and Celestia-Gnome

Discuss Celestia's features, adaptations and Addons for use in educational environments
Topic author
mauro.fraboni
Posts: 6
Joined: 15.02.2011
With us: 8 years 2 months

Lua_Edu_Tools_1.2beta8.zip and Celestia-Gnome

Post #1by mauro.fraboni » 17.02.2011, 20:24

I have installed Celestia Gnome 1.6.0 in my Linux Distribution Ubuntu 10.04 LTS - the Lucid Lynx.
The program runs fine.
I installed the add ons Lua_Edu_Tools_1.2beta8 and Celstia is raising the error "Segmentation Fault".
I read in http://www.celestiaproject.net/forum/viewtopic ... 11&t=13162 that this version of Lua_Edu_Tools needs Celestia 1.6.1; is it true?
Should I download SVN version ?

This is a part the output of strace that shows a possible problem with EAGAIN error when accessing the luahookinit.lua file

open("luahookinit.lua", O_RDONLY|O_LARGEFILE) = 16
read(3, 0xa03b310, 4096) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN}, {fd=8, events=POLLIN|POLLPRI}, {fd=12, events=POLLIN|POLLPRI}, {fd=13, events=POLLIN|POLLPRI}, {fd=14, events=POLLIN|POLLPRI}, {fd=10, events=POLLIN|POLLPRI}], 7, 0) = 0 (Timeout)
read(3, 0xa03b310, 4096) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN}, {fd=8, events=POLLIN|POLLPRI}, {fd=12, events=POLLIN|POLLPRI}, {fd=13, events=POLLIN|POLLPRI}, {fd=14, events=POLLIN|POLLPRI}, {fd=10, events=POLLIN|POLLPRI}], 7, 0) = 0 (Timeout)
poll([{fd=3, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"5 \4\0O\0@\3\4\0@\3R\2\366\0\225\4\5\0P\0@\3O\0@\3%\0\0\0"..., 200}, {NULL, 0}, {"", 0}], 3) = 200
poll([{fd=3, events=POLLIN}], 1, -1) = 1 ([{fd=3, revents=POLLIN}])
read(3, "\1\2N\1\0\0\0\0\4\0@\4\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0", 4096) = 32
read(3, 0xa03b310, 4096) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"\225\10\t\0\3\0@\3E\0@\3F\0@\3Q\0@\3\0\0\0\0\0\0\0\0\377\1\0\0"..., 256}, {NULL, 0}, {"", 0}], 3) = 256
poll([{fd=3, events=POLLIN}], 1, -1) = 1 ([{fd=3, revents=POLLIN}])
read(3, "\1\2V\1\0\0\0\0\4\0@\4\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0\0", 4096) = 32
read(3, 0xa03b310, 4096) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN|POLLOUT}], 1, -1) = 1 ([{fd=3, revents=POLLOUT}])
writev(3, [{"\225\10\t\0\3\0@\3E\0@\3F\0@\3Q\0@\3\0\0\0\0\0\0\0\0\377\377\300\0"..., 1540}, {NULL, 0}, {"", 0}], 3) = 1540
read(3, 0xa03b310, 4096) = -1 EAGAIN (Resource temporarily unavailable)
read(3, 0xa03b310, 4096) = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=4, events=POLLIN}, {fd=3, events=POLLIN}, {fd=8, events=POLLIN|POLLPRI}, {fd=12, events=POLLIN|POLLPRI}, {fd=13, events=POLLIN|POLLPRI}, {fd=14, events=POLLIN|POLLPRI}, {fd=10, events=POLLIN|POLLPRI}], 7, 0) = 0 (Timeout)
read(16, "-- luahookinit.lua\n\nrequire \"lua"..., 8191) = 82
read(16, "", 8191) = 0
close(16) = 0
gettimeofday({1297842387, 175343}, NULL) = 0
gettimeofday({1297842387, 176693}, NULL) = 0
open("lua_edu_tools.lua", O_RDONLY) = -1 ENOENT (No such file or directory)
open("celxx/lua_edu_tools.lua", O_RDONLY) = -1 ENOENT (No such file or directory)
open("extras/lua_edu_tools/tools/lua_edu_tools.lua", O_RDONLY) = -1 ENOENT (No such file or directory)
open("extras/lua_edu_tools/lua_edu_tools.lua", O_RDONLY) = 16
close(16) = 0
open("extras/lua_edu_tools/lua_edu_tools.lua", O_RDONLY) = 16
fstat64(16, {st_mode=S_IFREG|0644, st_size=10025, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb73f3000
read(16, "-- lua_edu_tools.lua\n\nrequire \"c"..., 4096) = 4096
read(16, "l.Disable(gl.LINE_SMOOTH);\n g"..., 4096) = 4096
read(16, "elf,ch,cmods)\n ch = strin"..., 8192) = 1833
read(16, "", 4096) = 0
close(16) = 0
munmap(0xb73f3000, 4096) = 0
open("celutil.lua", O_RDONLY) = -1 ENOENT (No such file or directory)
open("celxx/celutil.lua", O_RDONLY) = -1 ENOENT (No such file or directory)

Avatar
Marco Klunder
Posts: 180
Joined: 20.02.2008
Age: 56
With us: 11 years 2 months
Location: The Netherlands

Re: Lua_Edu_Tools_1.2beta8.zip and Celestia-Gnome

Post #2by Marco Klunder » 18.02.2011, 20:34

mauro.fraboni wrote:I read in viewtopic.php?f=11&t=13162 that this version of Lua_Edu_Tools needs Celestia 1.6.1; is it true?
YES
mauro.fraboni wrote:Should I download SVN version ?
If you want to use beta8, YES
There is also a beta9, but again YES, that also needs v161 or SVN
beta8 and beta9 can be downloaded by the way at: http://gvince.perso.sfr.fr/celestia/lua/

The same webpage of Vincent also contains Lua_Edu_Tools v1.1.
That version can be used with Celestia v1.6.0.

Marco
Marco Klunder
email: marco.klunder@hccnet.nl
Windows7 Ultimate, PD 3.0 GHz, 2 GB of RAM, Nvidia GeForce 6700 XL
Celestia161 / SVN + Lua Edu Tools v1.2 Beta9 and Celestia160-ED

Avatar
t00fri
Developer
Posts: 8772
Joined: 29.03.2002
Age: 17
With us: 17 years
Location: Hamburg, Germany

Re: Lua_Edu_Tools_1.2beta8.zip and Celestia-Gnome

Post #3by t00fri » 18.02.2011, 21:38

If this is correct then it would be good to adapt the statement on the Motherlode that the lua_edu_tools 1.2beta8 are for Celestia 1.6.0.

Here is the exact quote from

http://www.celestiamotherlode.net/catal ... ities.html
++++++++++++++++++++++++++++++++++
Lua Edu Tools 1.2 Beta8 (for Celestia 1.6.0)
Note: This is a beta version! Download this multilingual version for using with Celestia 1.6.0
++++++++++++++++++++++++++++++++++

I would have thought that the author (Vincent) of the lua_edu_tools who uploaded these specs should know best for what version of Celestia his tools apply.

Fridger
Image

Avatar
Marco Klunder
Posts: 180
Joined: 20.02.2008
Age: 56
With us: 11 years 2 months
Location: The Netherlands

Re: Lua_Edu_Tools_1.2beta8.zip and Celestia-Gnome

Post #4by Marco Klunder » 19.02.2011, 09:25

t00fri wrote:I would have thought that the author (Vincent) of the lua_edu_tools who uploaded these specs should know best for what version of Celestia his tools apply.Fridger

Fridger, you're absolutely correct. Vincent is the first to know and he also reported it in earlier threads.

Please read thread http://www.shatters.net/forum/posting.php?mode=quote&f=11&p=121769.
There are also a few other trheads on the forum, regarding load problems at startup and I had some personal mailings with Vincent on this topic.

This prerequisite is also the reason why Celestia160-ED is not implemented with beta8/9, but happily, some fixes of Vincent regarding the loading problems also applied to earlier beta release, included in Celestia160-ED.

Although not documented at all places, below the formal statement of Vincent in the above mentioned thread:
Vincent wrote:The Lua Edu Tools package has been updated to v1.2beta8:
> http://gvince.perso.sfr.fr/celestia/lua ... 2beta8.zip

ChangeLog:
- Added new features from the lua plugins package:
    * Hertzsprung-Russell Diagram
    * Keplerian parameters (dynamically calculated)
- Picture box: replaced old 00's style buttons with new 10's style
- Addon box:
    * Made script associated to a specific addon launched whenever the checkbox is clicked, i.e., either activated or unactivated
    * Improved scripts (Galactic Center, Large Scale Universe, Dying Sun)
- Fixed bugs

Please note that v1.2beta8 requires Celestia 1.6.1.
A pre-compiled Windows executable (revision 4996) is available here:
http://gvince.perso.sfr.fr/celestia/dev ... 61_SVN.zip

Knowing this, was my reason to react on in this thread, but as mentioned, Vincent's own reaction here may be better...

Marco
Marco Klunder
email: marco.klunder@hccnet.nl
Windows7 Ultimate, PD 3.0 GHz, 2 GB of RAM, Nvidia GeForce 6700 XL
Celestia161 / SVN + Lua Edu Tools v1.2 Beta9 and Celestia160-ED

Avatar
t00fri
Developer
Posts: 8772
Joined: 29.03.2002
Age: 17
With us: 17 years
Location: Hamburg, Germany

Re: Lua_Edu_Tools_1.2beta8.zip and Celestia-Gnome

Post #5by t00fri » 19.02.2011, 11:23

Marco Klunder wrote:
t00fri wrote:I would have thought that the author (Vincent) of the lua_edu_tools who uploaded these specs should know best for what version of Celestia his tools apply.Fridger

Fridger, you're absolutely correct. Vincent is the first to know and he also reported it in earlier threads.
Marco,

I am sure you agree that newcomers cannot be expected to scan for all these "shattered remarks in shatters.net" ;-), before downloading the lua_edu_tools 1.2beta8 from the central downloading place for Celestia add-ons (the Motherlode), where it is written incorrectly and most misleading:

http://www.celestiamotherlode.net/catal ... ities.html

The Motherlode wrote:Lua Edu Tools 1.2 Beta8 (for Celestia 1.6.0)
Note: This is a beta version! Download this multilingual version for using with Celestia 1.6.0

The point was that Mauro and I had led already a long inquiry over in CelestialMatters,

http://forum.celestialmatters.org/viewtopic.php?t=398

because his lua_edu_tools didn't work with his celestia-gnome 1.6.0 version. In this context, I had of cource also noticed Vincent's shatters.net posts that celestia 1.6.1 was required with version 1.2.x of the tools. I already had formulated a respective post for mauro!

++++++++++++++++++++++++++++++++++
But since it was beyond my phantasy that Vincent had remained with an incorrect and most misleading description in the MAIN downloading place for the lua_edu_tools (the Motherlode), I have deleted my mail again before posting it ;-)
++++++++++++++++++++++++++++++++++

Notably since his 1.6.1 related mails were partially quite old and version 1.6.1 was only recently put into a form by us that it would compile with "contemporary" compilers... (notably regarding Linux)

Fridger

PS: as concerns myself, I have no demand for "educational" add-ons and hence I only checked the functioning of Vincent's edu tools two days ago (with Celestia.SVN) in the context of trying to help Mauro over at CM.
Image

Avatar
Fenerit M
Posts: 1880
Joined: 26.03.2007
Age: 12
With us: 12 years
Location: Thyrrenian sea

Re: Lua_Edu_Tools_1.2beta8.zip and Celestia-Gnome

Post #6by Fenerit » 19.02.2011, 13:34

Hi! A newbie question. I've read the Mauro's issues concerning the LUATOOLS under Linux both here and on CM, and also myself had noticed the misleadings amongst LUATOOLS' betas for Celestia 1.6 and for SVN 1.6.1. But there is one thing that I do not understood: when one does compile the SVN's trunk, is the code's update the same for all operating systems? If yes, on CM Mauro is saying to have compiled even the SVN, so it would have all the routines for loading the LUATOOLS 1.2 beta 8. Could such SEGFAULT be ought to the Linux's desktops environments? That is, the tools works fine on KDE but not on Gnome? I apologize for my intrusion here, but all the few times that I've played with Linux, I've found the KDE enviroment (SUSE 7.2) much better than Gnome (Mandrake -8).
Never at rest.
Massimo

Avatar
Marco Klunder
Posts: 180
Joined: 20.02.2008
Age: 56
With us: 11 years 2 months
Location: The Netherlands

Re: Lua_Edu_Tools_1.2beta8.zip and Celestia-Gnome

Post #7by Marco Klunder » 19.02.2011, 16:06

Understood and agreed. ML should be corrected on this point.
Shatters calls Vincent :!:

But that unfortunately will not help Mauro with his v160 version. :?

Marco
Marco Klunder
email: marco.klunder@hccnet.nl
Windows7 Ultimate, PD 3.0 GHz, 2 GB of RAM, Nvidia GeForce 6700 XL
Celestia161 / SVN + Lua Edu Tools v1.2 Beta9 and Celestia160-ED

Vincent
Posts: 1356
Joined: 07.01.2005
With us: 14 years 3 months
Location: Nancy, France

Re: Lua_Edu_Tools_1.2beta8.zip and Celestia-Gnome

Post #8by Vincent » 20.02.2011, 12:30

Hi,

Sorry for not answering earlier, but I've been running a 39°C temperature for quite a few days.
Unlike summer which had only lasted a couple of weeks here in France, we've been facing quite
a rude winter for more than 4 months, with all its nice viruses. And it looks like it's not finished yet.

As to the Celestia version requirement issue, the Lua edu Tools 1.2beta8 indeed requires v1.6.1,
as mentionned both in the readme and in the shatters forum thread. I think that the required version
hasn't been correctly updated on the Motherlode when upgrading from beta7 up to beta8, either
because I didn't give the right information to Ulrich or simply because of a typo. I don't think that
looking for the culprit would be of any help here. In any case, I'm sorry for all the trouble it caused
here and on the CM forum. Finally, all this will be much more simpler when Celestia 1.6.1 is out.
I will then release v1.2 final, at last.

Anyway, this version issue should not be responsible for the errors reported by Mauro. Even with
1.6.0, the .lua files should be found and the tools loaded. I rather suspect a Linux specific
issue with the Lua package.path module or the environment variable LUA_PATH. Although I'm not
familiar with Linux, I'll try to investigate. I'll start with reading the CM discussion about this problem...
@+
Vincent

Celestia Qt4 SVN / Celestia 1.6.1 + Lua Edu Tools v1.2
GeForce 8600 GT 1024MB / AMD Athlon 64 Dual Core / 4Go DDR2 / XP SP3

Avatar
t00fri
Developer
Posts: 8772
Joined: 29.03.2002
Age: 17
With us: 17 years
Location: Hamburg, Germany

Re: Lua_Edu_Tools_1.2beta8.zip and Celestia-Gnome

Post #9by t00fri » 20.02.2011, 13:21

Vincent wrote:Hi,

Anyway, this version issue should not be responsible for the errors reported by Mauro. Even with
1.6.0, the .lua files should be found and the tools loaded. I rather suspect a Linux specific
issue with the Lua package.path module or the environment variable LUA_PATH. Although I'm not
familiar with Linux, I'll try to investigate. I'll start with reading the CM discussion about this problem...

Hi Vincent,

you may have read already in our CM thread that I had no problems running your lua_edu_tools 1.2beta8 under OpenSuSE 11.2 Linux with Celestia-gnome.SVN (r. 5136). Hence this is evidence for NO Linux specific PATH problem. I suspect however that you did essentially NO systematic testing of your tools under Linux? Meanwhile, with up-to-date Linux compilers (gcc 4.5.x) the original Celestia version 1.6.0 does'nt even compile anymore. It's simply outdated....

Hope you have recovered well, meanwhile,
Fridger
Image

Vincent
Posts: 1356
Joined: 07.01.2005
With us: 14 years 3 months
Location: Nancy, France

Re: Lua_Edu_Tools_1.2beta8.zip and Celestia-Gnome

Post #10by Vincent » 20.02.2011, 16:44

t00fri wrote:Hi Vincent,

you may have read already in our CM thread that I had no problems running your lua_edu_tools 1.2beta8 under OpenSuSE 11.2 Linux with Celestia-gnome.SVN (r. 5136). Hence this is evidence for NO Linux specific PATH problem. I suspect however that you did essentially NO systematic testing of your tools under Linux? Meanwhile, with up-to-date Linux compilers (gcc 4.5.x) the original Celestia version 1.6.0 does'nt even compile anymore. It's simply outdated....
Fridger
Hi Fridger,

Yes, I've read your thread on CM and was happy to learn that you had successfully run the tools with Celestia-gnome,
and that there is no LUA_PATH issue under Linux. So thanks for having both tested and reported it. As you guessed,
I was indeed unable to do some testing by myself, but quite a few users had previously also reported a successfull use
of the tools under different Linux flavors. I don't remember whether it concerned the KDE or GTK/GNOME version, though.


t00fri wrote:Hope you have recovered well, meanwhile,
Fridger
Thanks. I'm feeling a little bit better today. I think I will be just fine tomorrow for going to work ;-)
@+
Vincent

Celestia Qt4 SVN / Celestia 1.6.1 + Lua Edu Tools v1.2
GeForce 8600 GT 1024MB / AMD Athlon 64 Dual Core / 4Go DDR2 / XP SP3

Avatar
t00fri
Developer
Posts: 8772
Joined: 29.03.2002
Age: 17
With us: 17 years
Location: Hamburg, Germany

Re: Lua_Edu_Tools_1.2beta8.zip and Celestia-Gnome

Post #11by t00fri » 20.02.2011, 16:51

Vincent wrote:
t00fri wrote:Hi Vincent,

you may have read already in our CM thread that I had no problems running your lua_edu_tools 1.2beta8 under OpenSuSE 11.2 Linux with Celestia-gnome.SVN (r. 5136). Hence this is evidence for NO Linux specific PATH problem. I suspect however that you did essentially NO systematic testing of your tools under Linux? Meanwhile, with up-to-date Linux compilers (gcc 4.5.x) the original Celestia version 1.6.0 does'nt even compile anymore. It's simply outdated....
Fridger
Hi Fridger,

Yes, I've read your thread on CM and was happy to learn that you had successfully run the tools with Celestia-gnome,
and that there is no LUA_PATH issue under Linux. So thanks for having both tested and reported it. As you guessed,
I was indeed unable to do some testing by myself, but quite a few users had previously also reported a successfull use
of the tools under different Linux flavors. I don't remember whether it concerned the KDE or GTK/GNOME version, though.


t00fri wrote:Hope you have recovered well, meanwhile,
Fridger
Thanks. I'm feeling a little bit better today. I think I will be just fine tomorrow for going to work ;-)

Swine flu?? 39 degs of fever is quite something.

Fridger
Image

Vincent
Posts: 1356
Joined: 07.01.2005
With us: 14 years 3 months
Location: Nancy, France

Re: Lua_Edu_Tools_1.2beta8.zip and Celestia-Gnome

Post #12by Vincent » 21.02.2011, 17:34

t00fri wrote:Swine flu?? 39 degs of fever is quite something.
Fridger
No. A bacterial sore throat, just followed by a viral gastric flu.
It definitely wasn't my week !
@+
Vincent

Celestia Qt4 SVN / Celestia 1.6.1 + Lua Edu Tools v1.2
GeForce 8600 GT 1024MB / AMD Athlon 64 Dual Core / 4Go DDR2 / XP SP3

Topic author
mauro.fraboni
Posts: 6
Joined: 15.02.2011
With us: 8 years 2 months

Re: Lua_Edu_Tools_1.2beta8.zip and Celestia-Gnome

Post #13by mauro.fraboni » 28.02.2011, 14:20

I downoloaded the SVN, I compiled it for GNOME and I received the same error; I am running Linux Distribution Ubuntu 10.04 LTS - the Lucid Lynx
I made the same in Windows and everything is running fine.

Vincent wrote that it could be possible that it is need a LUA_PATH environment variable; I do not have it now.
Should I add it to /etc/environment ? Should I set it with the path of LuaEduTools ?

thanks mauro


Return to “Celestia in Education”

Who is online

Users browsing this forum: 2 guests