Posts by john71

by john71
Yesterday, 15:49
Forum: Development
Topic: scattersim and scattertable tools
Replies: 1
Views: 27

Re: scattersim and scattertable tools

There is this old thread about something similar:

http://forum.celestialmatters.org/viewtopic.php?t=389
by john71
18.05.2019, 17:50
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 410
Views: 20563

Re: Celestia 1.7.0 Development Thread

I found one more problem: the new qt build has a low fps problem, it is somehow '"lagging". Celestia 1.6.1 is seamless on the same spot with no fps problem or any lagging. The win version of the new build is much better in this regard, but not as smooth as the 1.6.1 version. As I wrote ear...
by john71
07.05.2019, 16:05
Forum: Help Central
Topic: celestia 1.7.0
Replies: 12
Views: 2057

Re: celestia 1.7.0

OK, thanks, I will try it!
by john71
07.05.2019, 16:04
Forum: Add-on releases
Topic: Extrasolar Planets (updated catalogue)
Replies: 21
Views: 1126

Re: Extrasolar Planets (updated catalogue)

Nice work!
by john71
05.05.2019, 18:22
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 410
Views: 20563

Re: Celestia 1.7.0 Development Thread

OK, I didn't know that. Anyway, not that important...
by john71
05.05.2019, 17:39
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 410
Views: 20563

Re: Celestia 1.7.0 Development Thread

OK, here are the screenshots:

2019-05-05 19_35_08-Window.png
2019-05-05 19_35_38-Window.png
2019-05-05 19_35_58-Window.png
2019-05-05 19_36_25-Window.png
2019-05-05 19_36_46-Window.png


Added after 1 minute 51 seconds:
I mean fading orbits are not working...
by john71
05.05.2019, 11:08
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 410
Views: 20563

Re: Celestia 1.7.0 Development Thread

Considering the old bugs: the new build works just fine! :clap:

New bug: in the qt version (64 bit) partial trajectories are not working...
by john71
04.05.2019, 10:27
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 410
Views: 20563

Re: Celestia 1.7.0 Development Thread

cartrite, The cone and the sphere should be BLACK, because it has no texture at all.

The original problem was that the cmod files were totally transparent or invisible.

If you see anything, even a black silhouette, it is good. It works then.
by john71
02.05.2019, 11:14
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 410
Views: 20563

Re: Celestia 1.7.0 Development Thread

Nice! :clap:

Yes, you need another sphere to have an inner surface.

Try this Dyson-sphere from Motherload, it has inner surface:

http://www.celestiamotherlode.net/creators/sbowers/impossibledyson.zip
by john71
01.05.2019, 16:16
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 410
Views: 20563

Re: Celestia 1.7.0 Development Thread

onetwothree, Here is another bug.

Maybe it is the same problem.

Large cmod objects around stars (megastructures) are also invisible.

Here is an ssc file (problem2). If you search for one2 in the Solar System, you will find it, but the cmod file is invisible - again.

problem2.7z
(7.45 KiB) Downloaded 7 times
by john71
01.05.2019, 11:09
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 410
Views: 20563

Re: Celestia 1.7.0 Development Thread

onetwothree , I have fixed Celestia to show them. But they are shown only if their parent body is visible. Is such behaviour is ok for everybody? Thank you very much! :clap: Visible parent bodies are OK, but I use a lot of invisible barycenters to build multiple star systems. I hope it cannot be a ...
by john71
30.04.2019, 16:37
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 410
Views: 20563

Re: Celestia 1.7.0 Development Thread

pirogronian, Thanx, I will sign up.
by john71
30.04.2019, 14:13
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 410
Views: 20563

Re: Celestia 1.7.0 Development Thread

OK, thanks.

The problem is not the location, but the invisible cmod file. You can see the location, the right radius, but it is invisible...
by john71
30.04.2019, 14:10
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 410
Views: 20563

Re: Celestia 1.7.0 Development Thread

They have huge cmod files, hundreds of MB.

But this simple, very small cone won't work either.

Should I write to Onetwothree?
by john71
30.04.2019, 14:08
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 410
Views: 20563

Re: Celestia 1.7.0 Development Thread

I have many cities on the surface of planets and moons, They just disappeared, both in the win and the qt version. :fie:

The win version has many other problems but the qt version works nicely - apart from this problem...
by john71
30.04.2019, 14:06
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 410
Views: 20563

Re: Celestia 1.7.0 Development Thread

Yes, I wrote about it a few weeks ago. This is the same problem. :think:
by john71
30.04.2019, 13:56
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 410
Views: 20563

Re: Celestia 1.7.0 Development Thread

There is definitely a problem with surface features in the new build.

I made a small ssc file with a cmod cone to prove it.

Extract the attached file in the extras folder.

Go to Earth, hit enter and type "one1".

Celestia will find the object, but it is invisible.

Added after 24 seconds:
problem.7z
(1.09 KiB) Downloaded 9 times
by john71
12.04.2019, 10:06
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 410
Views: 20563

Re: Celestia 1.7.0 Development Thread

I hope the diffuse function is still working, it is essential for building large scale diffuse structures around other models. :think:
by john71
11.04.2019, 18:32
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 410
Views: 20563

Re: Celestia 1.7.0 Development Thread

Onetwothree, yes, of course, I will try to do that!

Right now I'm looking for more bugs.

+ 2. bug: a Dyson-sphere 3d model with 1 AU radius totally disappeared, it is invisible (in the 'qt' version).
by john71
11.04.2019, 14:14
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 410
Views: 20563

Re: Celestia 1.7.0 Development Thread

Thanks, Lafuente_Astronomy! In the "qt" version, it works now! I just had to CHECK the "Moons" box! Strange. The "win" version exe file does not work well in this regard, there are no moons in it. By the way, why are there 2 exe files? + new bug: I have big cities on th...

Go to advanced search