Posts by cartrite

by cartrite
30.11.2019, 08:03
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 709
Views: 164895

Re: Celestia 1.7.0 Development Thread

Did you try to build with cmake? From the error list, it looks like your using the visual studio project files to build it. I used to have all kind of problems generating project files correctly. So now I just use cmake.
cartrite
by cartrite
29.11.2019, 17:18
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 709
Views: 164895

Re: Celestia 1.7.0 Development Thread

I was able to compile and run the latest master for win32 and didn't have any problems with the build or running the program. It is using a virtual machine thpugh. Vmware running windows 7. It's using msvc 2017.
cartrite
by cartrite
22.11.2019, 09:56
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 709
Views: 164895

Re: Celestia 1.7.0 Development Thread

I never considered symlinks the problem because of the image below. If you notice the top line in the log, it says it is loading an image from textures/hires/earth-clouds-hs-32k/level0/tx_0_0.dds. That folder is a symlink. The ctx file that points to it is also a symlink. So some symlinks do work in...
by cartrite
20.11.2019, 12:13
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 709
Views: 164895

Re: Celestia 1.7.0 Development Thread

I'm sorry for any inconvenience this may have caused you. It seems to be a bug with my system and symbolic links. Or something in Celestia's newer code that affects symbolic links on my system. If I extract the folder I posted into usr/local/share/celestia/extras, it works. If I create a symbolic li...
by cartrite
19.11.2019, 23:46
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 709
Views: 164895

Re: Celestia 1.7.0 Development Thread

I don't know if both installations have identical data. They both have the data that were a part of their versions. I am sure that the addon is the same. With the old version it loads and the new version it doesn't. Look at the images I posted. One says it is loading files from extras/3dmars. The ot...
by cartrite
19.11.2019, 15:59
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 709
Views: 164895

Re: Celestia 1.7.0 Development Thread

It looks like it loads for you. But not for me. Go figure.
I get this with the new version-c7432f10.
version-c7432f10.jpg


And this with the old version-e80b06e6.
version-e80b06e6.jpg

cartrite
by cartrite
19.11.2019, 14:20
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 709
Views: 164895

Re: Celestia 1.7.0 Development Thread

I don't think it has much to do with cmod handling. I think it has more to do with planet handling. In the extras folder. Probably with the ssc file. This is what mine looks like. Modify "Mars" "Sol" { Mesh "mars-mons-valles-131.cmod" Radius 3396 #small Atmosphere { Hei...
by cartrite
18.11.2019, 23:46
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 709
Views: 164895

Cmod models do not work/load.

Hate to rain on everybody's parade here but I downloaded the latest commit from github today and noticed that cmod addons I have don't work anymore. I running open suse leap 15.0 now. On the same laptop listed below. I built the qt version with cmake. The build worked and got installed in /usr/local...
by cartrite
04.05.2019, 10:38
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 709
Views: 164895

Re: Celestia 1.7.0 Development Thread

Oh. Ok. :smile:
by cartrite
04.05.2019, 10:23
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 709
Views: 164895

Re: Celestia 1.7.0 Development Thread

I don't know either. I downloaded john71's problem files to test if they were visible. A black cone is visible, What is it supposed to look like. I guess you got a cone also with a test on 1.6.1.
by cartrite
03.05.2019, 20:50
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 709
Views: 164895

Re: Celestia 1.7.0 Development Thread

Not on my system. I haven't tried the win build. This is linux qt version.

Added after 45 seconds:
The cone is john71's model.
by cartrite
03.05.2019, 20:39
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 709
Views: 164895

Re: Celestia 1.7.0 Development Thread

I tried the new commit and there still seems to be a problem. I tried john71's problem file for surface features.

05042019a.jpg


Added after 1 minute 11 seconds:
The other problem files were also invisible.
by cartrite
11.04.2019, 20:48
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 709
Views: 164895

Re: Celestia 1.7.0 Development Thread

Concerning the Invisible Moon, go check if an asteroid and a dwarf planet have the same invisibility(For example, go to Ceres, then to Pluto). If they have, just uncheck "Moons", "Asteroids" and "Dwarf Planets" in the "View Options". Only then will they be vi...
by cartrite
08.04.2019, 22:01
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 709
Views: 164895

Re: Celestia 1.7.0 Development Thread

One available here
by cartrite
08.04.2019, 10:43
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 709
Views: 164895

Re: Celestia 1.7.0 Development Thread

From what I see, you may be correct. The reason ceres is circular is a line was left out of dwarf-planets.ssc for Ceres. Oblateness 0.068 # Thomas et al, Nature, 8 Sep 2005 I'm unqualified to judge if that line should be used. I'm only stating something has changed. I noticed that for ceres at least...
by cartrite
08.04.2019, 10:25
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 709
Views: 164895

Re: Celestia 1.7.0 Development Thread

Tried a simple fix. Copied and renamed asteroid.jpg to ceres.jpg. Works but ceres is now circular. In the past it was shaped like an oval. So this is an *.ssc issue.
by cartrite
08.04.2019, 10:05
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 709
Views: 164895

Re: Celestia 1.7.0 Development Thread

My added post got lost :eek: Anyhow I looked into the asteroid and dwarf planet issue. It past versions, asteroid.* was loaded when selecting and going to ceres. Now a blank sphere is shown but no texture is loaded. The log says it trys to load ceres.*. In past versions, asteroid.* was loaded. This ...
by cartrite
08.04.2019, 09:30
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 709
Views: 164895

Re: Celestia 1.7.0 Development Thread

I just built the win version from commit 9a851f0e (5446) with win 7 running on VMWare. I can confirm the that the selection process behavior above. But it is also in the qt version running on Linux Tumbleweed. Typing in "muphrid" shows nothing and hitting enter selects nothing. Typing in &...
by cartrite
30.03.2019, 20:02
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 709
Views: 164895

Re: Celestia 1.7.0 Development Thread

I don't know much about it either. But from what I am reading, it looks like a nightmare.

Added after 1 minute 2 seconds:
Hope I'm wrong.
by cartrite
30.03.2019, 13:00
Forum: Development
Topic: Celestia 1.7.0 Development Thread
Replies: 709
Views: 164895

Re: Celestia 1.7.0 Development Thread

In the beginning of this thread, there was mention of porting to opengl es. Then to Android. From what I read, a lot of the code that can't be used in opengl es has already been depreciated in opengl 3. Like glbegin/end, everything in between, etc. Are there any plans on how this will be done? And p...

Go to advanced search